Linea di comando

StartPage | << Indietro | Avanti >>
Guida di ZipGenius 5

Scegli un argomento - per altri argomenti leggi l'Indice

Introduzione al programma
Caratteristiche di ZipGenius
Archivi supportati
Setup automatico

Barre degli strumenti
Personalizzazione dell'interfaccia
Integrazione con Windows

Creare un nuovo archivio
Estrarre files
Aggiungere files e cartelle
Visualizzare files in anteprima
Linea di comando

E-mail e pubblicazione sul Web
Usare FTPGenius

Requisiti hardware
Risoluzione di problemi
Contatti

In questa guida troverai tantissime informazioni che ti aiuteranno a scoprire e usare al meglio ogni funzione del programma che hai scaricato dalla Rete.

Grazie per aver preferito ZipGenius fra tanti altri programmi concorrenti.

- Il Team di ZipGenius 5 -


Perché è spesso necessario comprimere i files?

Introduzione al programma

Perchè é spesso necessario comprimere i files?

La risposta a questa domanda diventata sempre più ovvio col passare del tempo e il conseguente diffondersi di Internet: perché il modo di lavorare di domani è già arrivato. Oggi molte persone collaborano a distanza via Internet e spesso non si sono mai incontrate personalmente, anche se insieme sviluppano progetti e altro; per poter lavorare queste persone sono costrette a spedirsi documenti di ogni genere tramite Internet. Se questi documenti fossero inviati così come sono stati creati (cioé: non compressi), il trasferimento di quei files diventerebbe un'operazione lunghissima, noiosa e improduttiva, che non apporterebbe alcun beneficio alla produttività dell'azienda di cui i due "colleghi a distanza" sono dipendenti; al contrario, i programmi di compressione permettono loro di ridurre le dimensioni dei files che vogliono scambiarsi e, nel contempo, consentono di inviare più files contemporaneamente, compressi in un unico file. Tutto ciò non fa altro che rendere il loro telelavoro molto più veloce e produttivo.

Ma i vantaggi della compressione non sono riservati ai soli lavoratori. Chiunque può trarre beneficio dalla compressione dei files: gli studenti, per esempio, possono archiviare le loro ricerche su Internet e portarle a scuola in un floppy o in un CD-R, mentre, gli artisti del fotoritocco possono scambiarsi immagini in modo molto più agevole tramite i files zip.

Gli archivi compressi, inoltre, possono risultare molto utili anche se si desidera eseguire un backup dei dati più importanti come i files vitali del sistema, e proprio ZipGenius 5 è stato dotato di potenti funzioni di backup, in modo da consentire l'immediato recupero di tutti i dati eventualmente perduti.

Introduzione | Archivi supportati da ZipGenius | Caratteristiche di ZipGenius 5 |
 Aggiornamenti | Requisiti di sistema | Setup automatico


Archivi supportati da ZipGenius

Introduzione al programma

Archivi supportati

ZipGenius (come il nome lascia intendere) attua un pieno controllo sugli archivi in formato ZIP, ai quali ha affiancato una forma speciale di archivio: CZIP. Questo tipo di archivio non è altro che un ARCHIVIO ZIP CRIPTATO. Questo formato può essere letto soltanto da ZipGenius 1.4 o versioni successive e da nessun altro programma concorrente che non supporti esplicitamente tale formato.

Oltre questi, ZipGenius può gestire più o meno direttamente altri formati di compressione/archiviazione. Ecco quali sono (per avere maggiori informazioni su un tipo di archivio, clicca sulla sua estensione):

  • ZIP / CZIP, JAR, 7z, EAR, WAR, XPI, PK3, SQX: tutte le funzioni.
  • CAB
  • RAR, ACE, TAR, TAZ, TGZ, GZ, Z, BZ2: questi files possono essere letti e ZipGenius può estrarre files da essi. Compressione non supportata.
  • ARJ, ARC, LHA/LZH, ZOO: ZipGenius può aprire questi archivi per leggerne il contenuto, ma è necessario un apposito programma esterno per modificare il contenuto o per creare archivi di questo tipo.
  • PAK
  • WAL: skin per WinAmp® (trattata come un file zip, può essere ottimizzata)
  • WMZ: skin per Windows Media Player (trattata come un file zip, può essere ottimizzata).
  • EXE: files autoestraenti in formato ZIP, ACE e RAR.
  • Tutti i documenti in formato proprietario prodotti da OpenOffice.org/StarOffice 6.x (trattati come files zip, possono essere ottimizzati)

ZipGenius supporta i files creati con OpenOffice.org/StarOffice 6.x. Sebbene si tratti di una suite di programmi per ufficio, i files generati dai programmi di OpenOffice.org altro non sono che comunissimi files ZIP. All'interno di questi sono inseriti alcuni files XML che OpenOffice.org riesce a leggere come se componessero un documento unico; mediante ZipGenius adesso è possibile modificare il contenuto di quei files in modo molto semplice poiché ZipGenius può trattare i documenti di OpenOffice come se fossero files ZIP normali.

A partire da questa versione è stato introdotto il supporto all’ottimizzazione dei file di OpenOffice/StarOffice 6.x: in modalità "NORMALE" il programma rileva l'apertura di un documento di OpenOffice.org/StarOffice 6.x e chiede all'utente se desidera attivare la funzione "Ottimizza documenti OpenOffice.org". Questa funzione permette di comprimere ulteriormente i files prodotti da OpenOffice.org e StarOffice 6.x.

La stessa funzione può essere attivata direttamente dal menù contestuale associato a tali tipi di file, ma solo dopo aver abilitato il supporto di ZipGenius a OpenOffice.org/StarOffice 6.x dal pannello delle opzioni.

Introduzione | Archivi supportati da ZipGenius | Caratteristiche di ZipGenius 5 |
 Aggiornamenti | Requisiti di sistema | Setup automatico


Caratteristiche di ZipGenius 5

Introduzione al programma
Caratteristiche di ZipGenius

Gestione archivi______________________________

  • Oltre 20 tipi di archivi supportati
    Gestione di archivi ZIP oltre i 4 GB di dimensioni.
  • Gestione e Ottimizzazione dei documenti di OpenOffice.org/StarOffice 6.x
  • 4 diverse modalità di visualizzazione delle icone dei files archiviati
  • 2 modalità di visualizzazione dei file : completa (come in WinZip) o con visualizzazione Cartelle.
  • 5 livelli di compressione (archiviazione files + 4 liv. di compressione)
  • Lettura automatica del commento dei files zip
  • Lettura automatica dei files ReadMe.txt tramite editor interno, con la possibilità di rilevare in questi i collegamenti a indirizzi Web o E-mail
  • Esportazione lista dei files nei formati (HTML, CSV, XML, TXT)
  • Creazione di files autoestraenti (SFX) con funzioni avanzate, in grado persino di avviare l'installazione di un programma eventualmente archiviato (utile per gli sviluppatori di software)
  • Smart Extract e Special Extract: per facilitare l’estrazione e l’organizzazione dei file
  • Cronologia Archivio
  • Creazione di archivi Multivolume (Disk Spanning)
  • Riparazione zip danneggiati + AutoTest
  • Drag and drop per aggiungere o estrarre files da un archivio
  • I formati diversi da ZIP hanno quasi le sue stesse funzioni disponibili
  • Ricerca file all’interno di un archivio
  • Cronologia Archivio
  • Funzione MultiOpen per la gestione di più archivi.
  • Supporto al potente formato di compressione 7ZIP
  • Gestione dei Preferiti
  • Installazione automatizzata di programmi, temi e skin.
  • Evidenziatore File in base ai criteri selezionati.

Internet e mobilità______________________________

  • Interazione con palmari PocketPC tramite ActiveSync
  • Invio di archiv i o di files estratti singolarmente tramite il programma e-mail predefinito.
  • Pubblicazione di archivi o di singoli files estratti su Internet
  • FTPGenius (ftp client incorporato - nuova versione: consente l'upload dei files)
  • Invio via E-mail e pubblicazione della lista dei files
  • Time to Get! (Tool per calcolare il tempo stimato per il download di un archivio)
  • Supporto alla codifica UU/XX/MIME/BASE64

Interfaccia Utente__

  • Diverse configurazioni per utenti normali ed esperti
  • ZipGenius Starter: configuarazione guidata delle opzioni di ZipGenius
  • Assistente per il Primo Passo
  • Totale integrazione con la shell di Windows 98/ME/2000/XP
  • Menu contestuale di Windows personalizzabile
  • Ampie possibilità di personalizzazione
  • Interfaccia stile Esplora Risorse completamente ridisegnata, con Barra Operazioni Comuni
  • Interfaccia bilingue (italiano ed inglese) con possibilità di scaricarne di nuove da internet.
  • Possibilità di nascondere gli elementi dell’interfaccia
  • Voci di menu raggruppate per rendere più facile l’individuazione delle funzioni
  • Griglia per ordinare meglio i dati (facilita la lettura)
  • Il carattere selezionato per lo stile della finestra può essere usato anche per i bottoni e i menù di ZipGenius
  • Supporto per gli stili visuali di Windows XP

Funzioni Avanzate e Multimedia___________________
  • Supporto periferiche TWAIN (scanner e fotocamere digitali) per l’acquisizione di immagini e la successiva compressione in archivi ZIP.
  • Anteprima immagini
  • Estrazione selettiva di file multimediali.
  • Possibilità di interazione con accessori esterni
  • ZG Update: aggiornamento del programma via Internet
  • Gestione da riga di comando (command line)
  • Cutter (utilità per la divisione dei files in parti più piccole e viceversa)

Sicurezza e privacy_____________________________

  • Zip criptati (formato CZIP tramite CryptoZip 2.1) + 3 algoritmi di cifratura (Rijndael AES, Blowfish, Twofish)
  • Creazione di zip criptati Self-locking e Self-erasing
  • Password Manager
  • Funzioni di backup (es.: "Messaggi di Outlook Express" o "Cartella Documenti")
  • Scansione Antivirus (con programma esterno)
  • Sistemi integrati di segnalazione file “sospetti”
  • Opzioni per la Privacy
  • Supporto per la creazione e la lettura della FIRMA nei files zip

Introduzione | Archivi supportati da ZipGenius | Caratteristiche di ZipGenius 5 |
 Aggiornamenti | Requisiti di sistema | Setup automatico


Aggiornamenti

Introduzione al programma
Aggiornamenti

Lo sviluppo di ZipGenius non si ferma subito dopo la pubblicazione di una nuova versione, ma prosegue (teoricamente) all'infinito, pertanto talvolta sarà necessario aggiornare la copia di ZipGenius in tuo possesso.

La procedura di aggiornamento è automatica: tu non devi fare altro che aprire il menù "Aiuto" e cliccare su "Aggiornamenti"; ZipGenius tenterà di connettersi via Internet al sito M.Dev Software, ove uno script confrontare il numero di versione inviato con quello attualmente disponibile. Tutela della privacy: nessuna informazione personale viene inviata via Internet. Nel caso il tuo ZipGenius risultasse più "vecchio" rispetto a quello disponibile on-line, ZipGenius mostrerà informazioni aggiuntive e il link per raggiungere le pagine dei downloads da cui scaricare l'aggiornamento.

In Windows 2000, XP o Server 2003, solo un utente con i diritti di amministratore può eseguire l'aggiornamento del programma.

Introduzione | Archivi supportati da ZipGenius | Caratteristiche di ZipGenius 5 |
 Aggiornamenti | Requisiti di sistema | Setup automatico


Requisiti di sistema

Introduzione al programma
Requisiti di sistema

Requisiti minimi_______________________________

  • CPU Pentium 100 MHz
  • 16 Mb RAM
  • 8 Mb di spazio su hard disk
  • Mouse
  • Windows 98/ME/2000/XP
  • Windows 95 e NT4 non sono più supportati

Requisiti suggeriti_____________________________

  • CPU Pentium 200 MHz
  • 32 Mb RAM
  • 8 Mb di spazio su hard disk
  • Mouse
  • Modem e accesso a Internet
  • Windows 98 almeno

Introduzione | Archivi supportati da ZipGenius | Caratteristiche di ZipGenius 5 |
Aggiornamenti | Requisiti di sistema | Setup automatico


Barre degli strumenti

Interfaccia utente
Barre degli strumenti

Dal 1997, quando apparve la prima versione di ZipGenius, l’interfaccia utente si è sempre evoluta, ma mettendo sempre a disposizione dell’utente tre barre degli strumenti che permettevano di accedere alle funzioni più comuni. Adesso ZipGenius si presenta con un nuovo design ispirato a Windows xp, che permetterà anche ai meno esperti di familiarizzare immediatamente col programa. Tutte le funzioni principali sono raggruppate nelle seguenti barre:

PRINCIPALE
Mostra i comandi base di ZipGenius come “nuovo”, “apri” e così via.

Se vuoi usare i bottoni senza le rispettive etichette, clicca con il tasto del mouse su una barra qualsiasi e deseleziona la voce "Mostra etichette dei bottoni".
Se vuoi puoi visualizzare icone piccole: clicca su una barra qualsiasi con il tasto destro del mouse, quindi seleziona "Mostra icone piccole".

SIDEBAR
Studiata per facilitare l’uso del programma, permette di accedere a diverse funzioni, selezionabili col tasto Pannelli, che sono:

  • Barra Operazioni Comuni
  • Cartelle
  • Cronologia
  • Zip concatenati
  • Trova File

La SideBar può essere nascosta deselezionando l’omonima voce dal menu "Strumenti"> "Aspetto", così come la barra di stato e la InfoBar.

Barre degli strumenti | Barra operazioni comuni | Assistente Primo Passo | Cronologia Archivi | I dialoghi di ZipGenius | Integrazione con Windows | Visualizzazione Cartelle


Barra delle operazioni comuni

Interfaccia utente
Barra operazioni comuni

La Barra operazioni comuni rappresenta una delle novità più consistenti dell’interfaccia di ZipGenius. Essa è stata studiata per facilitare l’uso del programma ai principianti, riproducendo un ambiente familiare a quello di Esplora risorse.

Tutti i comandi principali sono stati spostati in questa Barra, oltre che nel menu contestuale. Nella Barra operazioni comuni troverai i comandi per accedere alle operazioni più frequenti, raggruppate in pannelli chiudibili proprio come in Windows XP. I vari pannelli sono, inoltre, sensibili al contesto; esempio: se non è aperto alcun archivio, saranno visualizzate solo le voci relative all’apertura e alla creazione dell’archivio stesso, mentre se sarà rilevato un archivio aperto, saranno visualizzate le voci che permettono di aggiungere, eliminare e visionare i file in esso contenuti.

I vari pannelli sono:

Operazioni comuni

  • Nuovo Archivio: permette di creare un nuovo archivio

  • Apri Archivio: permette di aprire un archivio

  • Chiudi Archivio: chiude un archivio corrente

  • Scan e Zip: avvia una procedura guidata che permette di acquisire immagini da periferiche TWAIN (scanner, fotocamere digitali) e comprimerle direttamente in un file ZIP, CAB, 7Z o creare un album autoeseguibile.

Operazioni Archivio

  • Aggiungi file: permette di aggiungere uno o più file a un archivio aperto

  • Aggiungi Cartella: permette di aggiungere cartelle ad un archivio aperto

  • Estrai file: avvia la procedura di estrazione di un archivio in una cartella specificata dall’utente

  • Estrai in CD-R/RW: permette di estrarre i file dell’archivio aperto nella cartella di premasterizzazione di Windows Xp, rendendoli pronti alla copia su CD-R/RW sfruttando il supporto di masterizzazione integrato in XP

  • Elimina file: permette di eliminare tutti o alcuni file presenti nell’archivio.

  • Anteprima: visualizza un file selezionato nell’archivio col programma ad esso associato

  • Rinomina archivio: rinomina l'archivio corrente

Altre Operazioni

  • Stampa lista dei file: stampa la lista dei file contenuti nell’archivio

  • Firma archivio: permette di aggiungere all’archivio una firma personalizzata contente il proprio indirizzo e-mail, l’homepage e la foto.

  • Esporta lista dei file in html/xml/csv/txt: salva la lista dei file in uno dei formati indicati

  • Crea Autoestraente: permette di creare un archivio autoestrente (SFX) che non necessita della presenza di un programma di gestione zip (come ZipGenius) per essere letto.

Barre degli strumenti | Barra operazioni comuni | Assistente Primo Passo | Cronologia Archivi | I dialoghi di Zipgenius | Integrazione con Windows | Visualizzazione Cartelle


Assistente "Primo Passo"

Interfaccia utente
Assistente "Primo Passo"

L’assistente primo passo permette agli utenti che usano la configurazione normale di accedere alle funzioni avanzate di ZipGenius. In questa nuova versione il pulsante “Primo passo” non esiste più perchè l’assistente è diventato una barra posizionata in alto alla finestra principale, garantendo così una maggiore semplicità di utilizzo: tramite la casella a scorrimento sarà possibile scegliere una fra le tante funzioni offerte, secondo che un archivio sia stato aperto o meno; cliccando"VIA" il programma avvierà la funzione prescelta e la completeràquasi automaticamente, con un intervento minimo (e persino nullo in alcuni casi) da parte dell'utente.

Quando si usa ZipGenius in modalità “NORMALE”, la barra è visibile per impostazione predefinita, mentre nella modalità “ESPERTO” è nascosta. Tuttavia puoi decidere se visualizzarla o nasconderla selezionando o meno la voce “Assistente Primo Passo” dal Menu “Strumenti” | “Layout” .

Come accennato, non tutte le funzioni sono sempre disponibili: alcune, infatti, sono accessibili se - per esempio - è stato aperto un archivio o se questo è stato creato con un formato diverso da zip: ZipGenius provvederà a disabililtare automaticamente tali funzioni.

Barre degli strumenti | Barra operazioni comuni | Assistente Primo Passo | Cronologia Archivi | I dialoghi di Zipgenius | Integrazione con Windows | Visualizzazione Cartelle


Cronologia archivi

Interfaccia utente
Cronologia archivi

La cronologia archivi permette di visualizzare i file che sono stati aperti con ZipGenius in ordine cronologico, permettendo di aprirli facendo semplicemente click sul nome del file. Se l’archivo non esiste, viene rimosso automaticamente dalla cronologia.

Sono visualizzate oltre alla data di apertura (rappresentata anche graficamente dall’icona numerata) altre informazioni come il percorso dell’archivio e il numero di volte che è sato aperto.

Per un maggior livello di sicurezza, ZipGenius permette di crittografare e quindi proteggere da sguardi indiscreti la cronologia degli archivi aperti: basta selezionare la casella “Crittografa Cronolologia” nella scheda “Sicurezza e Privacy” presente nella sezione Opzioni | Avanzate.

ATTENZIONE: modificando questa opzione perderai la cronologia archivio precedente

Barre degli strumenti | Barra operazioni comuni | Assistente Primo Passo | Cronologia Archivi | I dialoghi di Zipgenius | Integrazione con Windows | Visualizzazione Cartelle


I dialoghi dei files di ZipGenius

StartPage | << Indietro | Avanti >>
Interfaccia utente
I dialoghi dei files di ZipGenius

A differenza di tanti altri programmi, ZipGenius, si serve di un dialogo di apertura files diverso, simile a quello già usato in Office 2000 e ritrovato su Windows 2000; entrambi usano un dialogo di apertura in grado di aprire direttamente cinque percorsi predefiniti: ZipGenius, invece, fa anche di più. Non solo è possibile accedere a sei percorsi predefiniti, ma è anche possibile aggiungere alcuni percorsi preferiti: basta sfogliare le cartelle del sistema per raggiungere la preferita e premere il tasto "AGGIUNGI AI PREFERITI". Se invece si desidera rimuovere l'elenco delle cartelle preferita, basta cliccare su "Azzera lista preferiti".

Barre degli strumenti | Barra operazioni comuni | Assistente Primo Passo | Cronologia Archivi | I dialoghi di Zipgenius | Integrazione con Windows | Visualizzazione Cartelle


Integrazione con Windows

Interfaccia utente
Integrazione con Windows®

ZipGenius è disegnato per integrarsi al meglio con Windows. Dopo l'installazione, infatti, ZipGenius avrà a disposizione due menù contestuali associati rispettivamente ai soli archivi zip e a tutti gli altri files e cartelle. Per fare apparire uno di questi menù bisogna selezionare un file e cliccare con il tasto destro del mouse.

E’ possibile selezionare quali voci visualizzare nel menu contestuale, selezionandole nell’apposito box della scheda “Menu contestuale” presente nella sezione Opzioni > Avanzate. Le voci disponibili sono:

Estrai qui
Questo comando pemette di estrarre i files nella cartella in cui si trova l’archivio zip.

Pubblica su Internet
Attiva FTPGenius e trasferisce gli archivi selezionati su un server FTP (sul tuo sito, in pratica).

Contenuto
Farà apparire una finestra riportante il contenuto dell'archivio selezionato, dalla quale si potranno anche estrarre i files zippati o aprire l'archivio con ZipGenius.

Crea EXE
Trasforma l'archivio zip selezionato in un archivio autoestraente (SFX).

Spedisci via e-mail
Ti permette di creare un nuovo messaggio e-mail, cui troverai allegati i files selezionati. Questa funzione sfrutta il programma e-mail predefinito nel tuo sistema.

Estrai qui in [percorso]
Simile a ESTRAI QUI, ma in questo caso i file vengono estratti in una sottocartella il cui nomeè quello dell’archivio

Estrai in [percorso]
Estrae automaticamente tutti i files nella percorso indicato.

Installa
Estrare tutti i files dall'archivio e avvia l'installazione. Questo comando è disponibile solo se il file zip è contenuto il file "setup.exe ".

Questo è invece il menù associato agli altri tipi di files o cartelle:

Aggiungi
Aggiunge i files selezionati ad un archivio.

Crea [nome archivio].zip
Crea un nuovo archivio con i files selezionati e gli assegnerà il nome di uno dei suddetti files.

Crea e spedisci via e-mail
Come il comando precedente: crea un archivio e, in più, prepara un nuovo messaggio e-mail.

ZipGenius inoltre può comunicare sottoforma di suggerimento il numero di files contenuti in un archivio zip, più altre informazioni (se presenti) come la firma, il commento o l'eventuale presenza di un programma di installazione nell'archivio selezionato.

Inoltre è anche possibile trascinare files sopra un archivio zip per aggiungerli a quello grazie al completo supporto al Drag & Drop.

File OpenOffice/StarOffice 6.x

Se dal pannello delle Opzioni (sezione “Avanzate”, scheda “menu contestuale”) è stato attivato il supporto ai file di OpenOffice/StarOffice 6.x, nel menu contestuale dei file generati con queste suite per ufficio saranno attive le seguenti voci:

Apri in ZipGenius

Consente di trattare i documenti OpenOffice/StarOffice 6.x come normali archivi zip, permettendo ad esempio la modifica dei file xml e l’estrazione di immagini in essi presenti.

Attenzione: si sconsiglia di modificare il contenuto dei file presenti in un documento OpenOffice.org se non si sa bene cosa si sta facendo, si potrebbe correre il rischio di daneggiare il documento.

Ottimizza documento

Questa funzione permette di comprimere ulteriormente i files prodotti da OpenOffice.org e StarOffice 6.x e viene visualizzata solo se è stato abilitato il supporto di ZipGenius a OpenOffice.org/StarOffice 6.x dal pannello delle opzioni.

Attenzione: l'operazione di ottimizzazione di documenti OpenOffice.org/StarOffice può essere eseguita anche su documenti protetti con crittografia, ma tale azione potrebbe danneggiare il contenuto del documento stesso. Prima di procedere con l'ottimizzazione, accertarsi che il documento non sia crittografato.

Barre degli strumenti | Barra operazioni comuni | Assistente Primo Passo | Cronologia Archivi | I dialoghi di Zipgenius | Integrazione con Windows | Visualizzazione Cartelle


Visualizzazione cartelle

Interfaccia utente
Visualizzazione cartelle

Con ZipGenius è possibile visualizzare la struttura delle cartelle compresse in un archivio. Questa funzione è ora più intelligente: agisce infatti come un filtro sui file presenti nell’archivio: infatti basta fare doppio clic sul nome di una cartella e ZipGenius visualizzera i file in essa presenti. Per tornare alla visualizzazione completa dei file basta premere “Aggiorna”. Inoltre il programma può filtrare anche i files memorizzati senza percorso originale e nell'elenco delle cartelle comparirà il simbolo "(-)" con un'icona diversa. Cliccando due volte appariranno solo quei files.

Il pulsante “Livello superiore” permette di salire tra la gerarchia delle cartelle proprio come avviene in Esplora Risorse.

Questa funzione è raggiungibile dal menù collegato al bottone "Pannelli" della SideBar.

Barre degli strumenti | Barra operazioni comuni | Assistente Primo Passo | Cronologia Archivi | I dialoghi di Zipgenius | Integrazione con Windows | Visualizzazione Cartelle


Impostazioni generali

Opzioni
Impostazioni generali

Nella prima pagina del pannello delle opzioni vi sono le impostazioni generali del programma.

Associazioni
Innanzi tutto è data la possibilità di associare il programma a tutti i tipi di archivi che esso supporta: seleziona uno o più formati e clicca "Associa"; successivamente basterà un doppio click sull'icona che il programma attribuirà loro, per poterne leggere il contenuto con ZipGenius.

Configurazione di ZipGenius
Scegli la configurazione che ritieni più adatta alla tua dimestichezza con il PC. Se ti ritieni un utente medio o non molto avvezzo all'uso del PC puoi selezionare la configurazione "per tutti gli utenti" (l'indicatore "NORMALE" apparirà nella barra di stato), con la quale ogni operazione di ZipGenius è assistita dal programma, il quale interverrà per chiederti cosa vuoi fare e spiegarti quali saranno i risultati delle opzioni che scegli; Se invece ti ritieni un utente esperto potrai selezionare la configurazione "per utenti esperti" (l'indicatore "ESPERTO" apparirà nella barra di stato), che metterà a tua disposizione tutte le funzioni avanzate del programma.

Queste impostazioni avranno effetto subito dopo aver premuto "OK" nello stesso pannello delle opzioni.

Impostazioni generali | Informazioni utente | Aspetto del programma | Percorsi | Programmi di compressione esterni | Impostazioni avanzate | Dispositivi portatili


Informazioni utente

Opzioni
Informazioni utente

In questa pagina puoi inserire alcune informazioni personali che appariranno (se lo vorrai) nella firma che potrai aggiungere ad ogni archivio creato con ZipGenius.

Inserisci innanzi tutto nome, cognome, indirizzo e-mail e (se ne hai una) l'indirizzo della tua homepage; altre informazioni che ritieni utili per completare la tua firma potranno essere aggiunte successivamente come commento se deciderai di firmare l’archivio.

Puoi anche indicare un'immagine che ti rappresenti (per esempio: il logo dell'azienda in cui lavori): questa dovrà necessariamente essere in formato .BMP e dovrà misurare 121x121, altrimenti, oltre a risultare distorta, l'immagine sarà inutilmente ingombrante. Se non indicherai alcuna immagine, ZipGenius userà l'immagine predefinita fornita di serie.

Impostazioni generali | Informazioni utente | Aspetto del programma | Percorsi | Programmi di compressione esterni | Impostazioni avanzate | Dispositivi portatili


Aspetto

Opzioni
Aspetto del programma

Questa sezione è divisa in tre sezioni:

ZG Style___________________________

Questa sezione consente di modificare i colori e i caratteri usati in ZipGenius. Vi sono quattro sottosezioni:

1 - Colori e Font:

ZipGenius permette di usare una combinazione di colori carattere/finestra e un tipo di carattere diversi da quelli predefiniti e, inoltre, tale configurazione può essere salvata per essere utilizzata ogni volta che si usa ZipGenius.

Alcuni stili sono già definiti ma se hai scaricato la versione STANDARD dovrai scaricare anche il pacchetto Style Pack (se disponibile), che provvederà all'installazione degli stili creati da M.Dev Software; al contrario, se hai scaricato la versione SUITE troverai gli stili pronti per l'uso: ti basta selezionarne uno nella casella della sezione "Stile finestra".

Tuttavia puoi creare uno stile nuovo combinando insieme il colore e il tipo di carattere e il colore dello sfondo. Per cambiare il carattere innanzi tutto devi premere "Cambia carattere ": apparirà una finestra in cui potrai scegliere il tipo e la dimensione del carattere che più preferisci; successivamente puoi scegliere il colore del testo e dello sfondo premendo gli appositi tasti, rispettivamente "Colore testo " e " Colore sfondo". Entrambi mostrano un pannello da cui puoi scegliere un colore fra quelli predefiniti in Windows, ma se vuoi scegliere un colore diverso puoi premere il tasto "Altri..." alla base della stessa finestra.

A partire da ZG 5.1 la sidebar è cambiata e usa le SKINS. Quando salvi uno stile, questo memorizza anche la skin selezionata per la sidebar; puoi creare nuove skin: per sapere come fare scrivi a gui@zipgenius.it. Per installare nuove skins, basta cliccare due volte sulla loro icona (sono files con estensione .ZSK).

Se vuoi ripristinare lo schema di colori predefinito clicca su "Predefiniti".

Se lo stile creato è di tuo gradimento puoi assegnargli un nome nella casella a scomparsa degli stili, indicata dal cursore nella figura seguente, e premere il tasto " Aggiungi stile".

Se invece vuoi modificare uno stile esistente, selezionane uno, modificalo seguendo la procedura descritta sopra e premi "Aggiungi stile": ZipGenius ti chiederà se desideri modificare lo stile esistente.

Esportare un tema.
Premi il tasto "Esporta Tema" per far in modo che ZipGenius crei un file zip contenente tutto il necessario per l'installazione dell tema selezionato in un'altra copia di ZipGenius su un altro PC. ATTENZIONE: i fonts usati non verranno esportati per ragioni tecniche.

Temi per ZipGenius - inviare un nuovo tema a M.Dev Software.
Il primo Style Pack è disponibile per il download dal sito M.Dev Software per tutti coloro che hanno prelevato la versione STANDARD; altri pacchetti saranno pubblicati successivamente e saranno prelevabili dal sito M.Dev, nei quali saranno inseriti anche gli stili creati dagli utenti (basta esportare lo stile e spedirlo).

Temi per ZipGenius - installazione.
L'installazione degli stili aggiuntivi è cambiata in ZipGenius 5.1 ed è ancora più semplice: basta cliccare due volte sul file .ZTM contenente il tema da installare.

2 - Barre degli strumenti

In questa sezione sono disponibili tutte le impostazioni relative alle barre degli strumenti che compongono l’interfaccia:

  • Visualizza etichette pulsanti: abilita la visualizzazione delle etichette descrittive per i pulsanti;
  • Usa il Font selezionato per i pulsanti e i menu di ZipGenius: permette di visualizzare le scritte dei pulsanti e dei menu utilizzando il font scelto nella scheda “Colori e Font”.
  • Usa caratteri grandi: se avete abilitato la voce precedente i caratteri saranno visualizzati ingranditi.
  • Dimensioni icone:
    • Se vuoi visualizzare i bottoni con le rispettive etichette di testo, seleziona la casella "Mostra etichette dei bottoni".
    • Se vuoi puoi visualizzare icone piccole seleziona la casella "Icone piccole".
  • E’ inoltre possibile visualizzare o nascondere la barra operazioni comuni, la InfoBar, la barra di stato e la barra dell’assistente “Primo Passo” con le apposite voci.

A partire da ZG 5.2.5 anche la barra degli strumenti può essere personalizzata con immagini diverse sui pulsanti. Le skins per la barra dei bottoni hanno estensione .ZTK e anch'esse sono parte integrante degli stili di ZipGenius.

3 - VARIE

Click singolo del mouse: Seleziona quest’opzione se vuoi sostituire il doppio click con il click singolo per l'attivazione delle funzioni legate alla finestra dei files di ZipGenius.

Mostra griglia: se selezionato, visualizza una griglia che facilita la lettura quando la visualizzazione dei file è in modalità Lista

Selezione riga intera: questa opzione consente di evidenziare tutta la riga di appartenenza quando si seleziona un file nella lista mostrata da ZipGenius.

Le altre quattro opzioni consentono di nascondere o mostrare alcuni settori della finestra di ZipGenius (Sidebar, Barra di stato, Info bar, Barra "Primo Passo"): attivando tutte queste opzioni si disporrà dell'interfaccia più completa, disattivandole, invece, resterà visibile solo la barra dei bottoni e il resto della finestra sarà occupata dalla lista dei files (in modalità NORMALE la barra "Primo Passo" è sempre attiva e non può essere nascosta).

EVIDENZIATORE FILE____________________

Se i tuoi archivi contengono centinaia di file e non riesci a trovarne uno in particolare, la funzione evidenziatore file può aiutarti. Selezionando la casella “Abilita Evidenziatore File” ZipGenius evidenzierà i files corrispondenti agli attributi da te indicati nella casella “pattern”, come il nome di un file o un’estensione. Ad Esempio: se aggiungi un pattern del tipo ".DOC", ZipGenius evidenzierà tutti i file con estensione DOC contenuti nell’archivio; se invece aggiungi "MyPicture.jpg", ZipGenius evidenzierà solo il file chiamato "MyPicture.jpg". Se aggiungi una estensione di file simile ad un pattern nome di file (esempio: ".doc" e "somedocument.doc"), ZipGenius darà la priorità al nome di file.

Inoltre, quando questa caratteristica è abilitata, ZipGenius utilizzerà dei marcatori predefiniti per i seguenti tipi di file:

  • Readme.txt

  • Setup.exe, Install.exe, Install.com

  • Doppie estensioni di file sospette: ".VBS.*" and ".JS.*

LINGUA__________________________

Qui puoi scegliere se usare il programma in italiano o in inglese: questa scelta influenzerà i menù contestuali dei files associati a ZipGenius ma non la creazione dei file autoestraenti, per i quali è ora possibile scegliere sempre il modulo linguistico preferito.

E’ inoltre possibile verificare la presenza di nuovi moduli linguistici facendo clic sul pulsante “Connetti”: sarà visualizzata la lista dei pacchetti lingua disponibili; facendo click sul pacchetto desiderato partirà il download del file. Successivamente sarà possibile selezionare la lingua nell’apposito box.

A partire da ZG 5.1 l'elenco delle lingue disponibili mostra solo le lingue compatibili con la versione attuale del programma (es.: in ZG 5.1 i language packs v.102 non saranno visualizzati).

Impostazioni generali | Informazioni utente | Aspetto del programma | Percorsi | Programmi di compressione esterni | Impostazioni avanzate | Dispositivi portatili


Percorsi

Opzioni
Percorsi

In questa pagina del pannello delle opzioni è possibile indicare alcuni percorsi che potrebbero essere utili a ZipGenius.

Essa è suddivisa in due sottosezioni:

1) PRINCIPALE
In "Cartella Principale" puoi indicare la cartella in cui sono posti tutti gli archivi che apri più spesso. ZipGenius ti offre la possibilità di scegliere fra alcuni percorsi predefiniti, oppure di indicarne uno di tua preferenza. Cliccando su "OK" ZipGenius userà il percorso prescelto come cartella iniziale da cui saranno aperti gli archivi.

In "Programma di compressione esterno", è possibile indicare i percorsi dei programmi necessari per la gestione di archivi in alcuni formati diversi dal formato zip. Per ulteriori informazioni su questa sezione puoi leggere come installare i programmi esterni

2) Smart Extract

E’ una delle novità introdotte da ZipGenius 5. All’interno di questa sezione possono essere indicati i percorsi in cui il programma dovrà estrarre i file di immagini, musica, video, ecc. Ad esempio: se si dispone di un archivio contenente immagini, video e documenti, facendo click sulla voce “Smart Extract” del menu “Modifica”, ZipGenius estrarrà le immagini nella cartella indicata per le immagini, i documenti nella cartella indicata per i documenti, i video nella cartella indicata per i video e così via, il tutto in maniera completamente automatica e a vantaggio dell’organizzazione dei file.

Nota: Se si sta eseguendo ZipGenius sotto un sistema operativo diverso da Windows Xp, i percorsi saranno creati automaticamente la prima volta che si fa clic sulla voce “Smart Extract” del menu “Modifica”. Sotto Windows Xp i percorsi possono essere modificati (quelli originali non saranno modificati.

Impostazioni generali | Informazioni utente | Aspetto del programma | Percorsi | Programmi di compressione esterni | Impostazioni avanzate | Dispositivi portatili


Programmi di compressione esterni

Opzioni
Programmi di compressione esterni

In un’altra sezione di questa Guida sono spiegati i diversi formati di compressione supportati da ZipGenius, qui vedremo invece come installare i programmi esterni per la gestione dei file ARJ, ARC, ZOO, LZH, senza i quali ZipGenius non può modificarne il contenuto, ma può solo visualizzarlo.

Premi il tasto Opzioni e clicca su "Percorsi", quindi seleziona il formato per cui vuoi installare il programma esterno (.ARJ, per esempio); se conosci il percorso puoi scriverlo direttamente, altrimenti premi il tasto "Cerca". Fatto ciò, clicca su "Salva" e il percorso sarà memorizzato da ZipGenius.

ATTENZIONE! Se premi "OK" prima di aver premuto "Salva", il percorso non sarà memorizzato!

"Da quale sito...".
Questo bottone apre il tuo browser predefinito su una pagina del sito M.Dev Software riservata ai programmi esterni, nella quale troverai informazioni sui siti da cui puoi prelevare i programmi esterni richiesti da ZipGenius; per alcuni di essi potrà persino esservi la possibilità di scaricarli direttamente dal sito M.Dev Software.

Vedi anche:

  • Archivi supportati da ZipGenius

Impostazioni generali | Informazioni utente | Aspetto del programma | Percorsi | Programmi di compressione esterni | Impostazioni avanzate | Dispositivi portatili


Impostazioni avanzate

Opzioni
Impostazioni avanzate

G li utenti più esperti potranno configurare ulteriormente il programma cliccando sul tasto "IMPOSTAZIONI AVANZATE" nella finestra Opzioni.

Questa sezione è divisa in sette sottosezioni:

1) Impostazioni varie:

Anteprima con il programma associato
Quando questa casella è selezionata ZipGenius prova a mostrare il file selezionato usando il programma eventualmente associato.

Formato di esportazione predefinito
Selezionando quest’opzione insieme con uno dei quattro formati disponibili per l'esportazione della lista dei files, il tasto "ESPORTA" non mostrerà il menù ma esporterà la lista dei files direttamente nel formato scelto.

Mostra esecuzione programmi esterni
Questa casella dovrebbe essere normalmente selezionata poiché mostra i programmi di compressione esterni in esecuzione, come ARJ.exe o LHA.exe; tuttavia se si desidera evitare la comparsa di tali programmi basta deselezionare la casella in questione e attendere l'esito dell'operazione richiesta.

Mostra tempo impiegato
Al termine di ogni operazione di compressione/decompressione un messaggio comunicherà il tempo impiegato per il completamento.

Abilita funzione "Scan & Zip"
Selezionare quest’opzione per attivare il supporto alle periferiche di acquisizione di immagini (scanner, webcam, fotocamere digitali). Il tasto corrispondente apparirà nella finestra di ZipGenius.

Mostra progressione lettura...
Indicare oltre quale numero di files contenuti ZipGenius deve mostrare la barra di progressione della lettura dell'archivio. Il valore standard è 1000, il minimo è 50, il massimo è 30000.

Abilita controllo automatico dell’integrità dei file

Può accadere che un file Zip sia danneggiato, e ci si accorga di questo solo durante l’estrazione dei file o il compimento di altre operazioni. In questo caso occorre interrompere l’operazione, testare l’archivio e, in caso di errore, ripararlo. ZipGenius può svolgere automaticamente questo lavoro al posto tuo, verificando il file Zip durante l’apertura. Se poi desideri anche che ZipGenius lo ripari automaticamente, basta selezionare la voce “Ripara l’archivio automaticamente se danneggiato”.

2) Selezione dettagli

In questa sezione è possibile indicare quali colonne dovranno apparire quando è selezionata la visualizzazione "Dettagli". La scelta può essere eseguita manualmente oppure, selezionando la casella "Selezione automatica", sarà ZipGenius a selezionare quali caselle mostrare secondo la modalità scelta (NORMALE o ESPERTO).
Per selezionare le colonne usate più spesso basta cliccare "Predefiniti".

3) Antivirus

In questa sezione è possibile configurare l'interazione con un programma antivirus, il quale può essere attivato (a scelta) all'apertura di un archivio o su richiesta dell'utente.

4) File Temporanei

In questa scheda puoi scegliere la cartella che ZipGenius userà per i file temporanei. Se lo desideri puoi anche scegliere di posizionarla su un’altra unità disco, in modo da avere più spazio a disposizione per questi file. Per tornare alle impostazioni predefinite premi il pulsante “PREDEFINITE”.

Non cercare files temporanei obsoleti all'avvio di Windows®
Ogni volta che si avvia Windows, ZipGenius cerca una lista di files eventualmente residuati da una precedente sessione di lavoro e li cancella; selezionando quest’opzione è possibile impedire questa ricerca, soprattutto se nel proprio sistema vi sono troppi programmi in esecuzione automatica.

5) Crittografia (CrYptoZip 2)

Salva chiave numerica senza conferma.
Quando quest’opzione è selezionata ZipGenius salva automaticamente ogni chiave numerica usata per creare archivi CZip.
Vedi anche la sezione "Crittografare un archivio"

Forza elaborazione su disco rigido
Questa opzione forza l'elaborazione del file crittografato su disco rigido se l'algoritmo selezionato è CZIP. In questo caso l'operazione sarà più lenta ma con archivi di grandi dimensioni assicurerà la corretta riuscita dell'azione.

Metodo di crittografia predefinito
 Adesso è possibile scegliere tra quattro metodi di crittografia: CryptoZip (consigliato), Rijndael (AES), Blowfish, Twofish. Il primo usa una triplice chiave numerica, gli altri tre una frase chiave per crittografare gli archivi.

Tipo di archivio CZIP 2 predefinito
Qui puoi scegliere quale tipo archivio CZIP 2 deve essere indicato come predefinito.

6) INTEGRAZIONE SHELL

In questa sezione è possibile impostare i parametri relativi all’integrazione con Windows.

E’ possibile scegliere il livello di compressione da usare col menu contestuale tra “Massimo” (consigliato) e “Archiviazione” (nessuna compressione, i file sono riuniti in un'unica entità)

Selezionando la casella “Abilita menù contestuale” ZipGenius metterà a disposizione dell’utente in Esplora risorse un menù contestuale. Questo potrà apparire con un clic destro sull'icona di un file associato e offrirà una serie di funzioni, diversa secondo che si tratti di un archivio zip o di un archivio in altri formati.

E’ data inoltre la possibilità di scegliere se visualizzare il menù contestuale in forma intera oppure in cascata selezionando la rispettiva casella.

ZipGenius supporta i files creati con OpenOffice.org/StarOffice 6.x. Sebbene si tratti di una suite di programmi per ufficio, i files generati dai programmi di OpenOffice.org/StarOffice 6.x altro non sono che comunissimi files ZIP. All'interno di questi sono inseriti alcuni files XML che OpenOffice.org/StarOffice 6.x riesce a leggere come se componessero un documento unico. Selezionando la voce “Abilita supporto di ZipGenius ai documenti OpenOffice.org”, ZipGenius associerà al menu contestuale di questi file le voci “Apri in ZipGenius” e “Ottimizza” (permette di ridurre le dimensioni dei documenti).

In aggiunta è possibile disabilitare la visualizzazione delle icone di ZipGenius nel menu contestuale di Windows, o attivare il supporto per l’estrazione dei file semplicemente trascinandoli su una cartella.

In fine è possibile definire quali voci devono essere visibili nel menù contestuale.

7) SICUREZZA E Privacy

Avviso file con nomi di lunghezza superiore ai 255 caratteri
Recentemente, un gruppo di ricercatori ha scoperto che il formato Zip ha un “bug” che impedisce di gestire i file zip con nomi più lunghi di 255 caratteri. Ciò può dare luogo a due conseguenze: il sistema operativo può bloccarsi oppure, poiché il software antivirus non riesce a fare il controllo di questi file, l’archivio potrebbe contenere un virus. Questo è un caso raro, ma ZipGenius 5 cerca di aggirare l’ostacolo: il programma, infatti, permette all’utente di scegliere se vuole essere avvisato della presenza di un file con nome di lunghezza superiore ai 255 caratteri all’interno di un file zip, e ignorare questi file durante la lettura dell’archivio o durante l’estrazione.

E’ possibile disattivare quest’impostazione di sicurezza (a tuo rischio) selezionando la voce “visualizza sempre tutti i file”.

File recenti – Impostazioni Privacy

E’ possibile abilitare, disabilitare o cancellare all’uscita di ZipGenius, la lista dei file recentemente utilizzati.

Crittografa la Cronologia Archivio

Permette di crittografare e quindi proteggere da sguardi indiscreti la cronologia degli archivi aperti.

ATTENZIONE: modificando quest’opzione perderai la cronologia archivio precedente.

Cancella la Cronologia Archivio
Premendo questo pulsante sarà possibile cancellare il file della cronologia.

Impostazioni generali | Informazioni utente | Aspetto del programma | Percorsi | Programmi di compressione esterni | Impostazioni avanzate | Dispositivi portatili


Dispositivi portatili (PocketPC®)

Opzioni
Dispositivi portatili (PocketPC®)

ZipGenius è in grado di interagire con dispositivi portatili basati su Windows CE/Pocket PC, mediante l'intervento di Microsoft® ActiveSync®, il programma di sincronizzazione con il PC fornito a corredo di questi dispositivi.
ZipGenius è capace di individuare una relazione fra PC e dispositivo mobile e può sfruttare la cartella per la sincronizzazione dei files.

Per attivare questa cartella è necessario verificare se in ActiveSync è stata selezionata l'apposita opzione, che consente la sincronizzazione dei files fra i due apparecchi; per far ciò basta avviare ActiveSync e cliccare su "OPZIONI" per leggere la lista delle opzioni di sincronizzazione disponibili. Se la casella "FILES" non è selezionata occorrerà selezionarla, così ActiveSync provvederà a creare un'apposita cartella in "Documenti". Tale cartella altro non sarà che l'esatta copia della cartella "My Documents" del dispositivo e ogni modifica apportata in essa si rifletterà nel dispositivo portatile (e viceversa).

ZipGenius può usare questa cartella: può creare archivi in essa, può aprirli, può spostarli e copiarli da e verso quella, e può persino estrarvi files. Se il dispositivo è connesso al PC le modifiche saranno subito eseguite da ActiveSync, altrimenti saranno apportate alla sincronizzazione successiva.

Impostazioni generali | Informazioni utente | Aspetto del programma | Percorsi | Programmi di compressione esterni | Impostazioni avanzate | Dispositivi portatili


Creare un nuovo archivio

Azioni sugli archivi
Creare un nuovo archivio

Per creare un nuovo archivio basta premere il tasto "NUOVO ARCHIVIO" (presente sia sulla barra comandi principale sia nella barra operazioni comuni): se ti trovi in modalità "NORMALE", l'operazione sarà interamente guidata, altrimenti - in modalità "ESPERTO" - il programma attenderà che tu scelga cosa fare (aggiungere file, cartelle o immagini acquisite da periferiche TWAIN).

In modalità "ESPERTO" il dialogo per la creazione di un nuovo archivio offre la possibilità di scegliere immediatamente se aggiungere files o una cartella all'archivio che si intende creare; per utilizzare questa possibilità basta modificare l'impostazione del selettore che compare alla base del dialogo in questione.

Vedi anche:

  • Aggiungere files e cartelle
  • Acquisire immagini

Creare un nuovo archivio | Aggiungere files e cartelle | Estrarre files | Cancellare file | Rinominare un archivio | Firmare un archivio | File Readme.txt | Installazione di programmi | Rinominare un file | Anteprima di file | Lista Zip | Creare archivi autoestraenti (SFX) | Password


Aggiungere files e cartelle

Azioni sugli archivi
Aggiungere files e cartelle

Perché un archivio sia creato è necessario aggiungervi uno o più files, altrimenti - sebbene sia stato premuto il tasto " Nuovo Archvio" - l'archivio non sarà creato.

La procedura è diversa secondo la configurazione scelta.
In modalità “NORMALE” le operazioni sono guidate dall'Assistente di ZipGenius, il quale provvederà a spiegare passo per passo tutte le operazioni possibili e le opzioni disponibili; in modalità “ESPERTO” invece l'Assistente non interverrà automaticamente e dovrai procedere come descritto di seguito:

Selezione files
Apparirà il dialogo di ZipGenius: in questo potrai selezionare uno o più files di qualsiasi tipo, quindi premi il tasto "Aggiungi ".

Opzioni di compressione
In questa finestra potrai selezionare alcune opzioni per la compressione:

1) Impostazioni generali:

  • Livello di compressione: i livelli disponibili sono cinque. Il primo serve soltanto ad archiviare i files senza ridurne le dimensioni originali e costituisce il metodo più veloce; il secondo e il terzo offrono efficienza di compressione e velocità medie; il quarto è il livello che offre il maggior livello di compressione e la minor velocità di esecuzione. N.B.: con i primi quattro livelli ZipGenius aggiunge i files del tipo GIF, JPG, TAR, GZ, ZIP, ARJ, ZOO senza comprimerli (come se selezionasse automaticamente il primo livello). Per tentare di comprimere anche questi tipi di files occorre selezionare il quinto livello, che costringe ZipGenius a tentare di comprimere questi files già compressi per natura.
  • Cancella files dopo l'inserimento: se vuoi che i files originali siano rimossi dalla loro posizione dopo averli aggiunti ad un archivio, puoi selezionare quest’opzione: ZipGenius aggiungerà i files all'archivio e li cancellerà dalla posizione originale.
  • Includi intero percorso: seleziona quest’opzione per aggiungere ogni file con l'intero percorso originale (ad esclusione della lettera dell'unità). Quando estrarrai questi files con l'opzione "Usa percorsi salvati" ZipGenius ricreerà i percorsi originali all'interno della cartella di destinazione.
  • Aggiungi sottocartelle: quest’opzione è disponibile solo se si sta aggiungendo il contenuto di un’intera cartella, dato che provvede ad aggiungere il contenuto di tutte le sottocartelle contenute in quella prescelta. ATTENZIONE! se estrarrai questi files con l'opzione "Usa percorsi salvati", ZipGenius provvederà a ricreare la cartella archiviate e tutte le sue sottocartelle, con il rischio di saturare il disco rigido nel caso la cartella archiviata fosse di dimensioni generose.

  • 2) Impostazioni avanzate:

  • Aggiungi files nascosti: quest’opzione permette di inserire in un archivio anche i files nascosti.
  • Aggiungi files solo se hanno l'attributo "Archivio": quest’opzione permette di inserire in un archivio soltanto i files dotati dell'attributo "archivio", escludendo, quindi i files di sistema.
  • Azzera l'attributo "Archivio": con quest’opzione ZipGenius rimuove l'attributo "Archivio" ai files che sta per aggiungere ad un archivio.
  • Salva i nomi in formato DOS : prima di Windows 95 i files non potevano avere nomi di lunghezza maggiore di otto caratteri più tre per l'estensione dopo il punto (il formato definito "8.3"); ancora oggi quest’opzione potrebbe risultare utile per creare archivi compatibili con il DOS in modalità reale (disponibile fino alla pubblicazione di Windows Millennium Edition) e con Windows 3.x. In generale quest’opzione è obsoleta ed è stata mantenuta solo per offrire retrocompatibilità.
  • Tipi di file: quest’opzione è disponibile solo se si sta aggiungendo il contenuto di un’intera cartella, e permette di aggiungere all’archivio solo i file della cartella che hanno una determinata estensione: ad esempio se si scrive “*.doc” ZipGenius aggiungerà al file zip solo i file di documento. Questa funzione è molto duttile e permette di usare i caratteri Jolly “*” e “?”.

Inoltre è possibile scegliere il TIPO DI INSERIMENTO:

  • Normale : i file sono aggiunti all’archivio. Se l’archivio contiene un file con lo stesso nome e percorso del file da aggiungere, il file verrà sovrascritto.
  • Aggiorna files esistenti: se l'archivio contiene files con lo stesso nome di quelli che stanno per essere aggiunti, ZipGenius sostituisce quelli archiviati con quelli da archiviare solo se questi ultimi sono più recenti.
  • Aggiungi e aggiorna: ZipGenius aggiorna i files archiviati con i files più recenti e aggiunge i files non già presenti nell'archivio.

E' possibile aggiungere il contenuto di una intera cartella: in modalità "NORMALE" basterà selezionare l'opzione aggiungi cartella nell'Assitente di ZipGenius, mentre se hai scelto la configurazione "ESPERTO" senza Assistente dovrai premere il tasto con la freccia nera accanto ad "Aggiungi" (oppure in entrambe le modalità, basterà fare clic sulla voce “Aggiungi Cartella” nella barra Operazioni Comuni). Comparirà un menù in cui dovrai selezionare "Aggiungi cartella", quindi dovrai selezionare la cartlla da aggiungere all'archivio.

Le opzioni sono le ste sse disponibili per l'inserimento dei files .

Creare un nuovo archivio | Aggiungere files e cartelle | Estrarre files | Cancellare file | Rinominare un archivio | Firmare un archivio | File Readme.txt | Installazione di programmi | Rinominare un file | Anteprima di file | Lista Zip | Creare archivi autoestraenti (SFX) | Password


Estrarre files e cartelle

Azioni sugli archivi
Estrarre files da un archivio

La funzione di estrazione dei files è unica per entrambe le configurazioni del programma, anche se le opzioni cambiano da un formato di archivio all'altro.

Per iniziare l'estrazione bisogna premere il tasto Estrai.

Se nessun file nella finestra di ZipGenius è stato selezionato, l'opzione "Tutti i files" sarà attivata automaticamente; se invece uno o più files sono stati selezionati, sarà attivata l'opzione "Solo files selezionati". In alternativa è possibile scegliere l'opzione "Solo files del tipo" con cui possono essere estratti i files con la stessa estensione (che dovrà peraltro essere indicata nell'elenco a scomparsa laterale).
L'opzione "Cartella", invece. è utile quando l'archivio contiene diverse cartelle e sottocartelle: ne potrai estrarre anche una sola, selezionandola nell'apposito elenco. ZipGenius automaticamente si disporrà in modo tale da estrarre anche le sottocartelle contenute in quella selezionata. Se, invece, l'archivio non contiene cartelle, quest’opzione non sarà disponibile.

A partire da ZG 5.1 hai più soluzioni per estrarre i files più velocemente: nella finestra delle opzioni di estrazione è stata aggiunta una barra laterale con i collegamenti alle cartelle principali del sistema; cliccando su uno di quei collegamenti, ZipGenius imposterà automaticamente quel percorso come destinazione.
Inoltre il tasto "Estrai" nella finestra principale e il menù rapido sono stati arricchiti con il sottomenù "Estrai in..." che replica i collegamenti suddetti: basta selezionare alcuni file e premere con il tasto destro del mouse per estrarre direttamente quei files in uno dei percorsi predefiniti. Se nessun file è selezionato, cliccando con il tasto destro si predisporrà ZG ad estrarre tutti i files in elenco.

Opzioni

Usa percorsi salvati
Con quest’opzione saranno ricostruiti i percorsi originali dei files archiviati, se questi erano stati compressi con le informazioni sul loro percorso (praticamente: se la colonna "Percorso" nella finestra principale non è vuota).

Apri cartella di destinazione
Al termine dell'estrazione sarà aperta la cartella di destinazione dei files da estrarre.

Al termine dell'estrazione avvia l'installazione
Questa opzione è disponibile soltanto se nell'archivio è contenuto un programma di installazione "Setup.exe" e permette di avviare l'installazione del programma zippato dopo aver estratto tutti i files ad esso collegati. E' consigliabile verificare se i files siano stati compressi con le informazioni sui percorsi originali: se così non fosse è opportuno attivare anche l'opzione "Usa percorsi salvati", altrimenti l'installazione del programma potrebbe fallire. Se non sai cosa fare premi il tasto "Primo passo" e scegli la voce "Installare un programma".

Al termine dell'estrazione chiudi ZipGenius
Ad estrazione terminata il programma si chiuderà da sè.

E' necessario scegliere il tipo di estrazione da effettuare fra quattro disponibili:

  • Non sovrascrivere - se un file con lo stesso nome di quello da estrarre è già esistente, ZipGenius non lo estrae.

  • Sovrascrivi sempre i files esistenti - Se identici ai files da estrarre, ZipGenius sostituisce tutti i files esistenti nella cartella di destinazione.

  • Estrai e aggiorna i files esistenti - se i files omonimi esistenti sono più vecchi di quelli da estrarre, saranno sostituiti da quelli più recenti.

Destinazione
Scrivi il percorso della cartella in cui desideri estrarre i files zippati oppure premi il tasto "Sfoglia". Ogni percorso inserito sarà memorizzato, così se dovrai usarlo ancora potrai selezionarlo nell'elenco a scomparsa.
Selezionando l'opzione "Crea cartella con il nome dell'archivio" potrai fare in modo che ZipGenius crei nel percorso indicato come destinazione una cartella con lo stesso nome dell'archivio. Es.: dall'archivio "prova.zip", potrai estrarre i files in "[destinazione]\prova ".

Estrai nel dispositivo portatile

Se ZipGenius ha rilevato la presenza di un dispositivo portatile come un computer palmare Pocket PC, nel dialogo per l'estrazione dei files apparirà l'opzione Estrai nel dispositivo portatile. Selezionando questa casella ZipGenius imposterà il percorso della cartella di sincronizzazione dei files come percorso di destinazione dei files da estrarre; se il palmare è connesso al PC, ActiveSync® provvederà immediatamente al trasferimento dei files verso il dispositivo, altrimenti ciò avverrà alla successiva connessione fra PC e palmare. Per maggiori informazioni, leggi la sezione "Dispositivi portatili".

Creare un nuovo archivio | Aggiungere files e cartelle | Estrarre files | Cancellare file | Rinominare un archivio | Firmare un archivio | File Readme.txt | Installazione di programmi | Rinominare un file | Anteprima di file | Lista Zip | Creare archivi autoestraenti (SFX) | Password


Cancellare files da un archivio

Azioni sugli archivi
Cancellare files da un archivio

Attenzione! Usare questa funzione con molta cautela!

Questa funzione è disponibile direttamente per gli archivi ZIP, CZIP, PAK, CAB, XPI, 7z mentre per tutti gli altri sono necessari appositi.

Per evitare cancellazioni accidentali le voci relative all’eliminazione dei file sono presenti solo nel menu contestuale.

La voce "Cancella" nel menù contestuale di ZipGenius agisce così:

  • se uno o più files nella lista sono selezionati il programma chiederà se si desidera cancellare i files selezionati;

  • se nessun file è selezionato il programma chiederà se si desidera rimuovere tutti i files dall'archivio. In caso di risposta affermativa ZipGenius cancellerà tutti i files dall’archivio, lasciandolo virtualmente pronto per l'inserimento di altri files. Se un archivio senza files sarà chiuso, questo si distruggerà automaticamente.

L' "Assistente Primo Passo" mette inoltre a disposizione la voce Distruggi archivio che cancella l'archivio integralmente.

In alternativa è possibile cancellare intere cartelle da un archivio, selezionandole (una per volta) dall'elenco delle cartelle e cliccando con il tasto destro del mouse.

Creare un nuovo archivio | Aggiungere files e cartelle | Estrarre files | Cancellare file | Rinominare un archivio | Firmare un archivio | File Readme.txt | Installazione di programmi | Rinominare un file | Anteprima di file | Lista Zip | Creare archivi autoestraenti (SFX) | Password


Rinominare un archivio

Azioni sugli archivi
Rinominare un archivio

ZipGenius ti dà la possibilità di rinominare direttamente un archivio. Ogni volta che apri un file compresso, nel menu “File” si attivano le voci “Rinomina Archivio” (disponibile anche nella barra Operazioni Comuni) e “Proprietà Archivio”. Quest’ultima voce, accessibile anche dal menu contestuale, visualizza non solo le proprietà dell’archivio, ma permette anche di rinominarlo proprio come avviene in Windows XP: basta selezionare il nome dell’archivio nell’apposita casella, modificarlo e poi premere “Rinomina”.

ATTENZIONE: non è possibile rinominare un archivio zip concatenato dopo la sua visualizzazione in ZipGenius, ma è possibile rinominarlo se si riapre l'archivio che lo contiene: in questo caso l'archivio che si vuole rinominare appare nella lista dei files zippati ed è possibile modificare il nome selezionandolo e selezionando “Rinomina file” dopo aver cliccato con il tasto destro sul file stesso (analoga funzione è disponibile nella sezione “Operazioni Archivio” nella Barra Operazioni comuni). In questo modo l'archivio esterno sarà aggiornato automaticamente con l'archivio zip concatenato appena rinominato.

Creare un nuovo archivio | Aggiungere files e cartelle | Estrarre files | Cancellare file | Rinominare un archivio | Firmare un archivio | File Readme.txt | Installazione di programmi | Rinominare un file | Anteprima di file | Lista Zip | Creare archivi autoestraenti (SFX) | Password


Firmare un archivio

Azioni sugli archivi
Firmare un archivio

Fin dalle precedenti edizioni, ZipGenius consente di creare una "firma" da inserire negli archivi zip; questa altro non è che un file aggiuntivo riportante il nome, l'indirizzo e-mail del creatore dell'archivio, una breve descrizione e la data e l'ora della creazione della firma. E’ anche possibile inserire l'indirizzo della propria pagina Web e un'immagine in formato.BMP di dimensioni 121x121 pixel; inoltre, le stesse informazioni possono essere inserite nell'archivio sotto forma di commento zip standard, cioé visibile anche da altri programmi concorrenti. La firma creata con ZipGenius, infatti, è visualizzabile solo da ZipGenius 1.3.x o superiore.

Una firma creata con ZipGenius 5, però, non può essere visualizzata da ZipGenius 1.3 o da ZipGenius Evoluzione giacché dalla versione 1.4 del programma è stato usato un sistema diverso rispetto alle edizioni precedenti, le quali non permettevano di inserire l’indirizzo Web e un’immagine.

Per creare una firma occorre fare click sul collegamento “Firma” presente nella sezione “altre operazioni” della Barra Operazioni Comuni, oppure fare clic su menu Strumenti | Firma | Nuova Firma.

Dopo aver creato la firma, ZipGenius aggiungerà il file infopak all'archivio aperto, ma questo non apparirà nella lista dei files; apparirà, invece, se si aprirà l'archivio con altri programmi che non supportano la tecnologia ZGSignTM.

Quando un altro utente di ZipGenius aprirà l'archivio firmato, il programma riconoscerà il file della firma e mostrerà questa automaticamente. Dalla stessa finestra si potrà, poi, mandare un messaggio e-mail o visitare l’home page dell'autore dell'archivio: basterà cliccare su l'uno o sull'altro.

Le informazioni personali (nome, e-mail, pagina web, immagine e altro) possono essere inserite nella pagina "Informazioni utente " delle opzioni di ZipGenius, così queste saranno inserite automaticamente ogni volta che si desidera creare una firma.

Creare un nuovo archivio | Aggiungere files e cartelle | Estrarre files | Cancellare file | Rinominare un archivio | Firmare un archivio| File Readme.txt | Installazione di programmi | Rinominare un file | Anteprima di file | Lista Zip | Creare archivi autoestraenti (SFX) | Password


Il file "ReadMe.txt"

Azioni sugli archivi
Il file "ReadMe.txt"

Quasi tutti gli archivi zip reperibili in Rete contengono un file chiamato "Readme.txt" in cui è possibile trovare avvisi e informazioni varie sul contenuto di quell'archivio. ZipGenius facilita l'operazione di lettura di questo file tramite la funzione ReadMe (che sarà visibile nella barra Operazioni comuni) , che estrarrà temporaneamente il file e lo mostrerà nel visualizzatore interno.

Per alcuni tipi di archivio (diversi dal formato zip) questa funzione non è supportata, quindi il tasto "ReadMe" resterà disabilitato.

Creare un nuovo archivio | Aggiungere files e cartelle | Estrarre files | Cancellare file | Rinominare un archivio | Firmare un archivio | File Readme.txt | Installazione di programmi | Rinominare un file | Anteprima di file | Lista Zip | Creare archivi autoestraenti (SFX) | Password


Installazione di programmi

Azioni sugli archivi
Installazione di programmi

Gli archivi zip sono spesso usati per distribuire programmi attraverso Internet. In questi archivi si trova generalmente il file "setup.exe" o simili, che serve ad avviare l'installazione del programma zippato; ZipGenius è in grado di rilevare questo file e di avviare l'installazione del programma a quello collegato.

Se il file "setup.exe" è individuato, il programma ne darà comunicazione nella barra di stato (messaggio: "SETUP") e abiliterà l'apposita voce Installa nel menu Azioni e nella Barra Operazioni Comuni.

ZipGenius estrarrà tutti i files contenuti nell'archivio, rispettandone l'eventuale ripartizione in sottocartelle, e avvierà automaticamente l'installazione; comparirà un messaggio che inviterà a premere il tasto "OK" solo al termine dell'installazione: premendolo anticipatamente, infatti, potrebbero residuare alcuni dei files estratti temporaneamente, mentre seguendo quel consiglio, ZipGenius provvederà a rimuovere tutti i files estratti per consentire l'operazione.

Questa funzione non è disponibile per tutti i formati di archivio supportati: per i formati per cui non è possibile avviare il setup, la voce "Installa" resterà disabilitata.

Creare un nuovo archivio | Aggiungere files e cartelle | Estrarre files | Cancellare file | Rinominare un archivio | Firmare un archivio | File Readme.txt | Installazione di programmi | Rinominare un file | Anteprima di file | Lista Zip | Creare archivi autoestraenti (SFX) | Password


Rinominare un file in archivio

Azioni sugli archivi
Rinominare un file in un archivio

ZipGenius 5 ti dà la possibilità di cambiare il nome dei files archiviati in formato zip.

Basta selezionarne uno e cliccare con il tasto destro del mouse, quindi dal menù dovrai scegliere la voce "Rinomina". Potrai rinominare il file come già fai con Esplora Risorse.

Creare un nuovo archivio | Aggiungere files e cartelle | Estrarre files | Cancellare file | Rinominare un archivio | Firmare un archivio | File Readme.txt | Installazione di programmi | Rinominare un file | Anteprima di file | Lista Zip | Creare archivi autoestraenti (SFX) | Password


Anteprima din un file archiviato

Azioni sugli archivi
Anteprima di un file archiviato

ZipGenius consente di vedere un file compresso in anteprima. Per far ciò, estrae il file selezionato in una cartella temporanea, lo mostra e, infine, lo cancella.

Tuttavia non tutti i files possono essere mostrati in anteprima: ciò dipende sia dal tipo di file selezionato, sia dalla configurazione scelta per il programma.

N.B.: è possibile vedere in anteprima un solo file per volta, quindi se selezioni più di un file, non potrai attivare la funzione "Anteprima" (ad eccezione della modalità “anteprima immagini”).

ZipGenius tenta di aprire il file selezionato con il programma associato a quel tipo di file; se nessun programma è associato, il programma tenterà di mostrarne il contenuto tramite il visualizzatore interno

Selezionando la voce “Anteprima" del menù contestuale del programma apparirà un menù dal quale sarà possibile costringere ZipGenius a tentare di mostrare il file con il programma associato, oppure di mostrarlo direttamente con il visualizzatore interno.

Se il file selezionato è un archivio zip (zip concatenati) sarà attivata la funzione "ZipList".

IL VISUALIZZATORE INTERNO

Tramite la finestra di questo sarà possibile leggere (o tentare di leggere) i files in formato testuale; se un documento contiene l'indirizzo di una pagina Web o un indirizzo e-mail nel formato mailto:tuonome@tuodominio.xx, il visualizzatore è in grado di riconoscerli e possono essere usati cliccando direttamente su essi.

Anteprima immagini

ZipGenius permette di visualizzare le immagini contenute in un archivio come un album, in una maniera molto simile alla modalità Anteprima di Windows XP: basta fare clic sulla voce “Anteprima immagini” del menu “Vista” e il programma visualizzerà al posto dei nomi dei file le miniature delle immagini. Ottimo per gli amanti della fotografia digitale!

Creare un nuovo archivio | Aggiungere files e cartelle | Estrarre files | Cancellare file | Rinominare un archivio | Firmare un archivio | File Readme.txt | Installazione di programmi | Rinominare un file | Anteprima di file | Lista Zip | Creare archivi autoestraenti (SFX) | Password


Lista Zip

Azioni sugli archivi
Lista Zip

Molti archivi zip contengono altri archivi zip, costituendo così quelli che sono definiti zip concatenati. ZipGenius permette di leggere il contenuto di questi archivi zip nella stessa finestra in maniera molto semplice e intuitiva, grazie alla lista ad albero simile a quella usata in Esplora Risorse da Windows.

Gli Zip Concatenati si distinguono - per comodità - in ARCHIVIO ESTERNO e SOTTOARCHIVI, ove il primo è il file zip che contiene tutti gli altri zip concatenati.

Se ZipGenius rileva la presenza di sottoarchivi in un file Zip, vedrai la voce "Lista Zip" abilitato nel menu “Pannelli”.Cliccando su questo apparirà un elenco in cui la prima voce è l'archivio esterno e tutti gli altri archivi elencati costituiscono il primo livello di sottoarchivi; a loro volta, infatti, i sottoarchivi possono contenere altri sottoarchivi, andando perciò a creare una struttura di sottoarchivi organizzata in livelli.

Per esaminare il contenuto di un sottoarchivio puoi:

1) cliccare due volte sull'icona del sottoarchivio nella finestra principale di ZipGenius...

2) oppure puoi cliccare due volte sull'icona del sottoarchivio direttamente nella lista degli zip concatenati.

Nel primo caso ZipGenius provvederà anche a mostrare la lista se ciò non è stato fatto in precedenza.

Ogni volta che cliccherai su un sottoarchivio ZipGenius mostrerà i sottoarchivi eventualmente contenuti in esso e contemporaneamente elencherà il contenuto di questo nella finestra principale. Se invece desideri visualizzare nuovamente il contenuto dell'archivio esterno, dovrai solo cliccare il tasto "Mostra archivio esterno" posto sopra la lista dei sottoarchivi zip.

ZipGenius consente anche di modificare il contenuto dei sottoarchivi zip come se si trattasse di uno zip normale; tuttavia il contenuto non può essere modificato nei sottoarchivi zippati nell'archivio esterno insieme alle informazioni sul percorso originale: in questo caso ZipGenius disabiliterà i comandi che consentono la modifica del contenuto.

Creare un nuovo archivio | Aggiungere files e cartelle | Estrarre files | Cancellare file | Rinominare un archivio | Firmare un archivio | File Readme.txt | Installazione di programmi | Rinominare un file | Anteprima di file | Lista Zip | Creare archivi autoestraenti (SFX) | Password


Creare archivi autoestraenti (SFX)

Azioni sugli archivi
Creare archivi autoestraenti (SFX)

I files zip possono essere aperti generalmente solo con programmi come ZipGenius o simili, quindi chi riceve un archivio zip e non dispone sul proprio PC di uno di questi programmi si trova in difficoltà.

E' giusto, quindi, far sì che il destinatario di un archivio zip sia messo in grado di poterlo leggere, anche se egli non dispone di ZipGenius (o altri simili): per far ciò è possibile creare archivi autoestraenti, comunemente chiamati SFX (abbreviazione di SelF-eXtracting). Questi altro non sono che archivi zip incorporati in un piccolo programma contenente l'algoritmo necessario per eseguire l'estrazione dei files.

ZipGenius può creare due tipi di SFX:

  • il primo SFX è definito standard, poiché provvede alla semplice estrazione dei files contenuti in esso;

  • il secondo è definito autoinstallante, giacché può estrarre tutti i files e avviare il file setup.exe (oppure "install.exe", oppure "install.com"), in genere corrispondente alla procedura d’installazione di un programma.

I tipi di file da cui è possibile creare file auto estraenti sono: ZIP, ARJ e LZH

Per avviare la procedura di creazione di un SFX basta fare clic sulla voce “Crea EXE” nel menu “Azioni”: apparirà l'assistente di ZipGenius che ti guiderà nella creazione e personalizzazione di un file SFX. Esaminiamo i vari passi secondo il loro ordine:

Titolo dell'archivio
Indica il titolo che dovrà apparire nella finestra del tuo file SFX. Se non è indicato nulla ZipGenius utilizzerà un titolo predefinito.

In questa stessa pagina potrai inoltre selezionare il modulo linguistico da usare per la creazione del SFX. ZipGenius dispone attualmente di un modulo linguistico Italiano e Inglese, ma altri saranno presto pubblicati sul sito www.zipgenius.it

La creazione di files autoestraenti può avvenire anche mediante la linea dei comandi e, in particolare, ZipGenius consente di creare files SFX molto evoluti anche dalla riga dei comandi, così com’è già possibile fare dall'interfaccia utente di ZipGenius; pertanto è ora possibile creare files SFX con o senza autorun, con o senza lista dei files, eccetera.

L'innovazione principale sta nel fatto che la sintassi è molto semplice e le opzioni per la creazione di tali archivi sono inserite mediante un file di testo: usare un file per inserire le opzioni consente di associare ad ogni archivio zip le opzioni adeguate, soprattutto nei casi in cui il comando "ZG -SFX" sia usato all'interno di files.BAT o.CMD per l'automazione delle procedure.

ESEMPIO: poniamo di voler creare due archivi SFX da due files zip, usando per ciascuno opzioni diverse. Nel file .BAT potremo inserire le seguenti due righe:

zg -SFX "C:\Test1.zip" -IT "C:\Documenti\Test1opz.txt"

zg -SFX "C:\Test2.zip" -US "C:\Documenti\Test2opz.txt"

Com’è chiaro, per ognuno dei files zip è possibile salvare le relative opzioni ed è possibile recuperarle successivamente senza doverle scrivere nuovamente.

Per scrivere il file delle opzioni è lo stesso ZipGenius ad avviare la procedura mediante il comando "zg -SFX -TEMPLATE": questo comando creerà un nuovo file delle opzioni sul Desktop (leggi le istruzioni per la compilazione), che potrà poi essere salvato in qualsiasi cartella e con qualsiasi nome.

ARCHIVIO AUTOINSTALLANTE
Questa pagina sarà visualizzata solo se il file zip contiene un programma d’installazione: in questo caso apparirà un box in cui potrai scegliere se creare un file SFX autoinstallante. Optando per quest'ultima ipotesi potrai anche decidere se far estrarre i files in un percorso unico riservato al tuo archivio SFX. Questa possibilità è fortemente consigliata nel caso in cui si desideri distribuire un programma mediante un archivio SFX, poiché i files saranno estratti in una sottocartella della cartella "TEMP" di Windows, al fine di evitare possibili problemi durante l'installazione del programma.

Destinazione predefinita

In questa finestra puoi indicare il percorso che ritieni ideale per l'estrazione dei files. Questo apparirà nella finestra dell'SFX.
E’ possibile anche indicare una chiave del Registro di Windows che il file SFX leggerà dal sistema di destinazione. Questa opzione è molto utile soprattutto per gli sviluppatori di pagine Web e di software che devono inviare files da estrarre in percorsi specifici, i quali però potrebbero essere diversi da un utente all'altro.
ZipGenius offre una serie di chiavi del registro predefinite:

  • HKCU\Software\Borland\Delphi\6.0\RootDir
    Indica il percorso in cui è installato Delphi 6.0

  • HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\Desktop
    Percorso della cartella Desktop per l'utente attuale

  • HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\Favorites
    Percorso della cartella Preferiti per l'utente attuale

  • HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\My Music
    Cartella Musica

  • HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\My Pictures
    Cartella Immagini

  • HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\My Video
    Cartella Video

  • HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\Personal
    Cartella Documenti

  • HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\Start Menu
    Cartella del Menù Start

  • HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\Startup
    Cartella Esecuzione Automatica

  • HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\Common Desktop
    Cartella Desktop comune a tutti gli utenti in un sistema Windows 2000 / Windows XP

  • HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\Common Favorites
    Cartella Preferiti comune a tutti gli utenti in un sistema Windows 2000 / Windows XP

  • HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\Common Programs
    Cartella Programmi comune a tutti gli utenti in un sistema Windows 2000 / Windows XP

  • HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\Personal
    Cartella Documenti comune a tutti gli utenti in un sistema Windows 2000 / Windows XP

Attenzione: alcuni dei percorsi predefiniti potrebbero non produrre effetti dopo la realizzazione del file SFX se questo viene usato in Windows 98/ME: questi sistemi operativi infatti non consentono profili utente avanzati come in Windows 2000/XP, pertanto è consigliabile l'uso delle chiavi relative all'utente (ossia quelle inizianti con HKCU).

E' possibile anche indicare chiavi personali.

Per esempio, se vogliamo che il file SFX legga il percorso contenuto nel valore "AppPath" mostrato in figura, dovremo copiare il nome della chiave evidenziato in giallo, aggiungere "\" e infine il nome del valore da leggere (AppPath). Si otterrà: HKEY_CURRENT_USER\SOFTWARE\M.DEV SOFTWARE\ZGTOOLS\APPPATH. Il nome del valore da leggere deve essere sempre messo alla fine del nome della chiave, altrimenti il file SFX tenterà di leggere il valore PREDEFINITO.
La parte iniziale del nome della chiave può essere scritta sia in formato lungo che in formato corto:

  • HKEY_CURRENT_USER oppure HKCU

  • HKEY_USERS oppure HKU

  • HKEY_LOCAL_MACHINE oppure HKLM

Le chiavi del registro contenenti percorsi sono le tre citate normalmente. Le variabili d'ambiente (es.: "%windir%") adesso sono supportate.

Sottocartella di destinazione - è possibile indicare in quale sottocartella nel percorso di estrazione indicato in precedenza (anche se esso dovrà essere letto dal Registro di Windows) andranno estratti i files. E' possibile indicare anche indicare sottocartelle su più livelli. Se la sottocartella indicata non esiste, essa sarà creata.

Icona dell'archivio
Qui puoi scegliere se far apparire l'icona predefinita per i files SFX, oppure se usare un'icona personalizzata; in quest'ultimo caso puoi scegliere premendo il tasto "Sfoglia" e caricando un file .ICO o files .EXE e .DLL contenenti icone. Se il file caricato sarà un .EXE o una .DLL puoi scorrere la lista delle icone in essi contenuti.

N.B. : l’icona selezionata sarà ridotta sempre a 256 colori.

Messaggio di avvio
Puoi far apparire un messaggio di lunghezza non superiore ai 255 caratteri quando il destinatario farà doppio clic sul tuo file SFX. Puoi scegliere fra tre tipi diversi di messaggio: Standard (per dare semplici comunicazioni), Informazioni (per dare informazioni importanti - il messaggio avrà i tasti "OK" e "Annulla") e Richiesta (per porre una richiesta all'utente - il messaggio avrà i tasti "Sì" e "No"). Se non vuoi mostrare alcun messaggio lascia in bianco l'apposita casella e premi Avanti.

Esecuzione di un file al termine
Se lo desideri, puoi fare in modo che il file SFX esegua uno dei files estratti.

Altre opzioni
Questo è l'ultimo passo se hai scelto di creare un archivio SFX standard. Qui puoi scegliere le altre impostazioni:

  • Files esistenti - scegli il comportamento del file SFX nei confronti di files già esistenti.
  • Lista dei files - consente di scegliere se rendere visibile la lista dei files contenuti nell'archivio SFX, se renderla invisibile sempre o solo inizialmente (l'utente potrà vederla premendo un apposito tasto nella finestra del file SFX).
  • Nascondi la scelta del tipo di sovrascrittura - puoi fare in modo che il destinatario dell'SFX non modifichi l'opzione precedente.
  • Permetti di disattivare l'esecuzione automatica... - permetti al destinatario di disabilitare l'esecuzione del file indicato nel passo precedente

  • Consenti all'utente di scegliere i file da estrarre - puoi permettere all'utente di selezionare i files da estrarre. Normalmente sono estratti tutti i files.

  • Mostra messaggio di conferma estrazione - al termine dell'estrazione apparirà un messaggio di conferma.

  • Espandi le variabili d’ambiente: permette di espandere le variabili di sistema come %windir%

  • Consenti interruzione durante l’estrazione: permette all’utente di interrompere il processo di estrazione.

  • Salva file di impostazioni…- permette di salvare un file di impostazioni da riutilizzare per le successive creazioni di SFX (vedere sopra).

A questo punto dovrai cliccare "Avanti" per avviare la creazione del file autoestraente.

Creare un nuovo archivio | Aggiungere files e cartelle | Estrarre files | Cancellare file | Rinominare un archivio | Firmare un archivio | File Readme.txt | Installazione di programmi | Rinominare un file | Anteprima di file | Lista Zip | Creare archivi autoestraenti (SFX) | Password


Password

 Azioni sugli archivi
Password

Puoi proteggere il contenuto di un archivio ZIP con una password: ciò non significa, però, che non si possa leggere il contenuto dell'archivio, poiché la password impedisce soltanto che i files siano estratti dall'archivio.

ZipGenius può proteggere un archivio con la password, ma questa funzione è stata solo mantenuta per motivi di compatibilità con le versioni precedenti e con i programmi concorrenti, poiché ZG offre il sistema CryptoZip, mediante cui gli archivi zip sono criptati e diventa impossibile leggerne il contenuto se non si conosce la chiave corretta.

Quando si vorrà estrarre dei files protetti con password, sarà possibile inserire questa nel dialogo di estrazione files; la password indicata verrà usata con i files su cui ha effetto, ma potrebbe capitare che fra i files selezionati per l'estrazione ve ne siano altri protetti con password diverse: in tal caso il programma chiederà di inserire nuovamente la password.

Consigli per la scelta della password

Nonostante la protezione tramite password sia più vulnerabile dei sistemi di crittografia, è ancora uno strumento molto utilizzato. Tenete presente queste semplici regole per la scelta di una password:

  • usate Password di almeno 8 caratteri; più la password è lunga, maggiori sono le combinazioni possibili e il tempo necessario per elaborarle dai Password cracker;
  • usate password “illogiche”; non usate nomi propri, date di nascite, nomi di cose concrete, ecc. , bensì combinazioni di caratteri casuali;
  • per aumentare notevolmente il grado di sicurezza della password usate combinazioni di LETTERE, NUMERI, MAIUSCOLE, MINUSCOLE, e se possibile anche PUNTEGGIATURA. Evitate di utilizzare la stessa password per proteggere più archivi;
  • cambiate periodicamente le password se vi è possibile.Non comunicate a nessuno la password, ma custoditela gelosamente;
  • i Password Manager sono una comodità, ma se è possibile, conviene custodire la lista delle password in luoghi diversi dal computer in uso. Nulla vi garantisce che anche il più potente sistema di crittografia sia violato in futuro.

Queste regole valgono anche per le “Passphrase” dei sistemi di crittografia, e vanno applicate in funzione delle vostre esigenze di sicurezza.

Creare un nuovo archivio | Aggiungere files | Estrarre files | Cancellare file | Rinominare un archivio | Firmare un archivio | File Readme.txt | Installazione di programmi | Rinominare un file | Anteprima di file | Lista Zip | Creare archivi autoestraenti (SFX) | Password


Antivirus

Operazioni avanzate
Antivirus

Il numero dei virus in circolazione cresce giorno dopo giorno, quindi ognuno dovrebbe avere un buon programma antivirus. Con ZipGenius puoi esaminare gli archivi che aprirai di volta in volta con l'antivirus installato nel tuo sistema.. Puoi scegliere se costringere ZipGenius a comandare la scansione del file ogni volta che aprirai un archivio, oppure se abilitare il solo supporto all'antivirus e lasciarti libero di eseguire la scansione ogni volta che vorrai.

Questa funzione deve essere abilitata dal pannello "Opzioni", nella pagina "Avanzate" > "Antivirus".
Prima di tutto, devi indicare il percorso completo del programma antivirus che intendi usare per l'esecuzione della scansione. Ogni programma richiede un percorso e un set di parametri specifici, perciò è compito tuo indicare quelli corretti. Puoi digitare il percorso manualmente oppure puoi cliccare su "Sfoglia" per indicare il file eseguibile dell'antivirus. Se ti serve aiuto, puoi cliccare il tasto "Lista Antivirus": ZipGenius aprirà il browser predefinito su una pagina del sito http://www.zipgenius.it/, nella quale è presente una lista di percorsi per gli antivirus già testati.

Il simbolo "%s" è un segnaposto: ZipGenius lo sostituirà automaticamente con il nome del file archivio del quale si desidera la scansione. Quando indicherai i parametri per l'esecuzione dell'antivirus, fai attenzione alla posizione in cui porrai tale simbolo, altrimenti la scansione potrebbe non avvenire.

Se eseguita all'apertura dell'archivio, al termine della scansione ZipGenius chiederà se l'antivirus ha trovato un qualunque virus.

Antivirus | Multivolume | Crittografia | Scan e Zip | ZG Album | Linea di comando | Esportare la lista dei file | Funzioni di Backup | Ottimizzazione documenti OpenOffice.org | Ottimizzazione skin Winamp/WMP | Funzioni di ricerca | MultiOpen


Antivirus

Operazioni avanzate
Archivi multivolume

Quando devi inviare un archivio via e-mail o su floppy disk devi stare attento alle dimensioni. Se ti connetti a Internet mediante connessioni ad alta velocità, inviare un grosso archivio può diventare un'operazione lunghissima; inoltre in alcuni paesi il foppy disk è ancora l'unità di memorizzazione rimovibile più diffusa. In questi casi la soluzione è la trasformazione dell'archivio zip in un archivio Multivolume, per la quale il file originario viene suddiviso in porzioni di dimensioni inferiori.

I comandi sono inseriti nella sezione "Archivi Multivolume" del menù Azioni e sono:

  • Dividi Archivio - trasforma l'archivio zip in archivio multivolume
  • Riunisci Archivio - esegue l'operazione inversa e ricostruisce il file zip originario

Il modo in cui ZipGenius crea questi archivi multivolume è diverso da quello degli altri programmi ed è un po' più logico:

1. Innanzitutto, devi creare un file zip sul disco rigido (come si fa normalmente);

2. clicca su "Dividi Archivi" per eseguire la trasformazione.

Questo metodo ti consente di modificare il contenuto del file zip anche all'ultimo minuto prima della trasformazione, poiché ZipGenius non crea archivi direttamente in formato multivolume: puoi creare e modificare il file zip come e quando vuoi, quindi puoi decidere se e quando dividerlo in porzioni di dimensioni inferiori.

Quando clicchi su "Dividi Archivio" devi scegliere l'unità di destinazione per il set di porzioni del file. Puoi scegliere sia un disco rimovibile (un floppy, per esempio), sia un disco rigido: in quest'ultimo caso, il programma ti chiederà dove creare la cartella "ZipGenius Span Output", nella quale saranno inserite le porzioni che verranno generate dalla divisione del file.

Inoltre, se scegli un disco rigido come destinazione, devi anche indicare la dimensione delle porzini che vuoi generare. ZipGenius offre diverse dimensioni predefinite fra cui scegliere, ma puoi anche indicare una dimensione personalizzata.

In alternativa, puoi scegliere di dividere l'archivio su un set di floppy disk: ZipGenius chiederà l'inserimento del primo disco del set e verificherà se contiene altri file. In tal caso, ZipGenius chiederà se desideri la cancellazione di quei files. ATTENZIONE: cancellando quei files sarà poi impossibile recuperarli.

Le porzioni di files avranno diverse estensioni:

  • .ZIP - questo sarà l'unico file leggibile dal programma
  • .z01 .. .zXX - queste saranno le porzioni di file risultanti dalla divisione

Attenzione: ZipGenius ha adottato questa nuova convenzione per l'identificazione dei files che compongono un archivio multivolume al fine di essere compatibile con WinZip®, ma altri programmi di compressione potrebbero non riuscire a leggere questi archivi.

L'azione opposta è "Ricostruisci Archivio" e serve per la ricostruzione del file originario: ti verrà chiesto in quale cartella desideri ricreare quel file.

Antivirus | Multivolume | Crittografia | Scan e Zip | ZG Album | Linea di comando | Esportare la lista dei file | Funzioni di Backup | Ottimizzazione documenti OpenOffice.org | Ottimizzazione skin Winamp/WMP | Funzioni di ricerca | MultiOpen


Why files compression is useful?

Operazioni avanzate

CryptoZip - crittografare files zip

Una delle più importanti caratteristiche di questa versione di ZipGenius è CryptoZip. Questa tecnica oggi offre una migliore protezione per gli archivi zip rispetto alla tradizionale password. Oggi esistono molti programmi per il recupero delle password dei files zip, i quali sono davvero abili nello scoprire la password corretta e consentire l'apertura del file zip protetto.

Al contrario, ZipGenius può crittografare i files zip usando quattro tipi di algoritmo:

  1. CZIP: è l'algoritmo proprietario di ZipGenius. E' lento (per questo è consigliato per i piccoli archivi) poiché codifica l'archivio byte per byte, quindi offrendo un certo margine di sicurezza. Devi inserire tre valori numerici fra 0 e 65535 ("0-0-0" non è consentito) e otterrai una combinazione su 281.474.976.71 0.656 possibili. Probabilmente può essere crackato, ma richiederebbe troppo tempo per farlo.
    Quando il file zip originale è di dimensioni superiori a 10 MB, l'algoritmo CZIP non è consigliato se si desidera un'esecuzione veloce (vedi di seguito).
  2. BlowFish: devi inserire una passphrase. Più questa è lunga, più sarà difficile da scoprire, più protetti saranno i dati. Più veloce di CZIP.
  3. TwoFish: devi inserire una passphrase. E' più veloce di CZIP e Blowfish, è più sicuro di Blowfish.
  4. Rijndael: devi inserire una passphrase- E' più veloce di CZIP ma più lento di Blowfish e Twofish, ma è il più sicuro di tutti.

ZipGenius 5 introduce il formati di file CZIP 2.1. Si tratta di un archivio zip crittografato, in grado di rendere disponibili alcune informazioni come il numero dei files all'interno, il nome o l'indirizzo e-mail dell'autore, eccetera; il nuovo formato CZIP 2.1, inoltre, consente di sapere subito se la chiave numerica (o la passphrase) usata è corretta o meno, quindi non è più necessario attendere la lettura dell'intero archivio per saperlo.
Oltre ciò, CZIP 2.1 consente la creazione di tre tipi di archivi crittografati:

  • Standard
  • Autobloccanti: dopo tre tentativi falliti di inserimento chiave/passphrase, l'archivio si blocca e diviene illeggibile.
  • Autodistruttivo: dopo tre tentativi falliti di inserimento chiave/passphrase, l'archivio si auto-cancella, lasciando inalterate solo le informazioni sull'autore dello stesso.

Se bisogna inviare un archivio CZIP a persone che non usano ZipGenius o programmi compatibili, adesso non è più necessario inviare loro anche un tool apposito per la decrittografia: ZipGenius 5 può creare archivi auto decriptanti (SDA: Self-Decrypting Archive), i quali si presentano sotto forma di file eseguibile.

ZipGenius oggi dispone di Password Manager per tenere traccia delle chiavi e delle frasi d'accesso usate di volta in volta. Il Password Manager può essere avviato sia dal menù Start, sia dallo stesso ZipGenius, ed esso consente l'esportazione della lista delle chiavi e delle frasi d'accesso.

ATTENZIONE! Una volta crittografato un file con CryptoZip, DEVI SEMPRE usare la stessa chiave usata per la crittografia, altrimenti il file resterà inutilizzabile. Per questo motivo è consigliabile che ZipGenius aggiunga automaticamente le chiavi e le password al Password Manager.

Puoi crittografare un file cliccando su Azioni>Crittografa/decodifica archivio nel menù principale.

Quando aprirai un file .CZIP file, ZipGenius chiederà l'inserimento della chiave o della frase d'accesso ad esso associata. Se il file CZIP è stato crittografato con l'algoritmo CZIP, devi indicare i tre valori fra 0 e 65535, altrimenti dovrai indicare la frase d'accesso.

Password Manager
Il nuovo Password Manager sostituisce la vecchia "lista delle chiavi CZIP" ed è un prodotto più completo, poiché è un'applicazione indipendente e consente una gestione completa della lista. ZipGenius può salvare automaticamente le chiavi e le frasi d'accesso nella lista del PM, se l'apposita opzione resterà abilitata durante la codifica di un file.

PM salva queste informazioni in un file cifrato al fine di offrire maggior protezione ai tuoi dati.
Quando PM viene eseguito per la prima volta, ti verrà chiesta una password per l'accesso, quindi vedrai la seguente finestra:

Con PM puoi:

  1. Caricare un file .ZGK
  2. Ricaricare il file della lista predefinita
  3. Copiare la chiave/passphrase selezionata negli appunti
  4. Esportare la lista delle chiaviin un file .ZGK
  5. Stampare la lista
  6. (Come il punto #3)
  7. Cancellare l'elemento selezionato
  8. Cambiare la password d'accesso
  9. (Uscita)

Vedrai la lista delle chiavi e frasi disponibili: devi soltanto sceglierne una e copiarla nel dialogo di apertura dei files CZIP; infatti, se non ricordi la chiave per aprire un file criptato, puoi cliccare su "Password Manager" e aprire il questa applicazione. In questo caso PM verificherà la presenza della associazione file/chiave nella propria lista e, se troverà la chiave corrispondente, la evidenzierà.

PM può anche essere usato per leggere altri files con le liste delle chiavi ma solo a condizione che questi siano stati creati dalla tua copia di PM: quando esporti le chiavi in un file .ZGK, PM aggiunge la password d'accesso attuale, al fine di eseguirne la verifica in momenti successivi. Se alla successiva riapertura del file .ZGK la password di accesso e quella di controllo non coincideranno si otterrà un errore. RICORDA: è assolutamente importante che la password d'accesso rimanga la stessa il più a lungo possibile, poiché essa viene usata anche come verifica della genuinità della lista delle chiavi in uso. Il file della lista predefinita verrà aggiornato ad ogni modifica della password, al fine di assicurare comunque l'accesso alle chiavi attualmente memorizzate.

I file ZGK possono essere creati usando l'apposito bottone nella barra degli strumenti di PM: il programma chiederà di reinserire la password di accesso a PM per eseguire una rapida verifica di sicurezza.

Antivirus | Multivolume | Crittografia | Scan e Zip | ZG Album | Linea di comando | Esportare la lista dei file | Funzioni di Backup | Ottimizzazione documenti OpenOffice.org | Ottimizzazione skin Winamp/WMP | Funzioni di ricerca | MultiOpen


Why files compression is useful?

Operazioni avanzate

Scan and Zip - importazione immagini da periferiche TWAIN

Fino a poco tempo fa, gli scanner piani erano l'unica soluzione per l'acquisizione delle immagini in formato digitale, ma oggi le fotocamere digitali sono una realtà alla portata di tutti e l'esigenza di archiviare le foto digitali è cresciuta; è per questo motivo che ZipGenius offre una versione potenziata di "Scan and Zip". Adesso Scan and Zip ha la forma di wizard e ti guida passo dopo passo nell'acquisizione di immagini da periferiche TWAIN, e nella loro successiva archiviazione.

RICHIESTE HARDWARE
Questa funzione richiede la presenza dei drivers TWAIN per poter funzionare: se la tua periferica di acquisizione immagini usa drivers diversi, ZipGenius non potrà importare le immagini.

Clicca sul comando "Scan & Zip" nella sidebar o nel menù principale.

Segui questi passi:

1) SCELTA FORMATO IMMAGINE.

Scegli in quale formato ZipGenius dovrà importare le immagini: se scegli il formato .JPG puoi anche scegliere un livello di qualità fra 0 e 99, ove 99 indica la qualità migliore. Però ricorda che maggiore sarà la qualità delle immagini, maggiori saranno le dimensioni del file prodotto (e viceversa). In alternativa, puoi scegliere il formato non compresso .BMP, le cui dimensioni sono facilmente riducibili.

2) SCEGLI UN NOME GRUPPO e IMPORTA.

Prima di tutto devi assegnare un nome al gruppo di immagini che stai per importare. Questo nome (seguito da un numero) verrà usato da ZipGenius per identificare i files con le immagini acquisite. Esempio, se il nome del gruppo è "Estate", si avranno i files:

  • Estate (0).jpg
  • Estate (1).jpg
  • ....
  • Estate (X).jpg

Dopo l'assegnazione di un nome al gruppo di immagini, puoi cliccare su "Importa" per avviare l'acquisizione. Assicurati che la periferica TWAIN sia connessa e accesa! Usa l'interfaccia proprietaria della periferica per la scelta e l'acquisizione delle immagini da inviare a ZG, quindi attendi che ZG finisca il salvataggio dei files nella cartella temporanea. Al termine vedrai l'anteprima della prima immagine importata: puoi vedere l'anteprima di tutte le altre immagini usando la barra di navigazione sotto l'anteprima stessa, e puoi vedere (ed eventualmente modificare) l'immagine in dimensioni reali cliccando su "Anteprima / Modifica" (potrai anche ruotare le immagini prima di archiviarle).

A partire da ZipGenius 5.1 puoi anche catturare il tuo desktop e creare degli screenshots dei tuoi lavori: per fare questo clicca su "Cattura Desktop". ZipGenius si ridurrà automaticamente per lasciarti libero di scegliere cosa "catturare"; puoi eseguire un numero teoricamente illimitato di catture: basta premere il tasto F1 sulla tastiera per catturare una schermata. Quando vuoi salvare le schermate catturate, premi F11 sulla tastiera: ZipGenius riapparirà e mostrerà i tuoi screenshots nel riquadro di anteprima.

3) COMPRESSIONE.
ZipGenius 5 permette la scelta del formato di compressione fra .ZIP (predefinito), .CAB e .7z. Scegli quello che più soddisfa le tue esigenze:

FORMATO | PRO | CONTRO
ZIP | Molto diffuso. Scegli questo formato per distribuire facilmente le tue fotografie. | Ha un buon rapporto di compressione con i files .BMP poiché questi non sono compressi per loro natura.
CAB | Buon formato di archiviazione: utile se si desidera conservare le immagini senza applicare compressione. | Rapporto di compressione molto basso. Non molto diffuso.
7z | Alto rapporto di compressione. Usa molte nuove tecniche di compressione ed è suggerito per l'archiviazione di files multimediali. | Non è conosciuto come il formato ZIP, pochi programmi lo supportano.

Se hai ZG Album installato, troverai anche l'opzione "EXE (Crea presentazione)". Questa opzione consente la creazione di presentazioni così da poter far vedere le immagini acquisite senza l'ausilio di programmi particolari (vedi: ZG Album).

Antivirus | Multivolume | Crittografia | Scan e Zip | ZG Album | Linea di comando | Esportare la lista dei file | Funzioni di Backup | Ottimizzazione documenti OpenOffice.org | Ottimizzazione skin Winamp/WMP | Funzioni di ricerca | MultiOpen


Why files compression is useful?

Operazioni avanzate

ZG Album - creare una presentazione

ZG Album è un nuovo componente opzionale per ZipGenius 5, distribuito nell'edizione SUITE ma installabile opzionalmente. Gli utenti dell'edizione STANDARD, invece, possono scaricarlo separatamente da www.zipgenius.it. ZG Album consente la creazione di presentazioni di immagini da inviare ai parenti e agli amici, senza che questi dispongano di un apposito programma per la visualizzazione.

Una presentazione può essere creata in due modi:

  1. Clicca su "Crea presentazione" nel menù principale: ZipGenius ti chiederà di scegliere una cartella contenente immagini.
  2. Clicca su "Scan and Zip" per importare le immagini da una periferica TWAIN e scegli ".EXE" come formato di archiviazione.

Quando ZipGenius sarà pronto a creare la presentazione, ti consentirà alcune personalizzazioni.
Scegli un titolo e modifica gli altri dettagli della presentazione, quindi nella sezione "Immagini" puoi scegliere le immagini da inserire nella presentazione e puoi scrivere un commento per ognuna di esse.

Da ZipGenius 5.1 è anche possibile proteggere gli slideshows con una password.

Quando avrai finito, dovrai cliccare su "Procedi" e ZipGenius creerà un file autoestraente speciale, contenente la presentazione da te creata.

Antivirus | Multivolume | Crittografia | Scan e Zip | ZG Album | Linea di comando | Esportare la lista dei file | Funzioni di Backup | Ottimizzazione documenti OpenOffice.org | Ottimizzazione skin Winamp/WMP | Funzioni di ricerca | MultiOpen


Linea di comando

StartPage | I<< Indietro | Avanti >>
Operazioni avanzate

Linea di comando

ZipGenius può anche essere usato mediante la sua linea di comando. Qui trovi un elenco di tutti i comandi disponibili. Ognuno di essi ha una propria sintassi.

  • add
  • backup
  • oerestore
  • extract
  • delete
  • destroy
  • print
  • export
  • mail
  • sfx
  • optim
  • encrypt

-add

  • Sintassi: zg.exe -addfile archivio file1 [file2 ... fileN] -NUM [-( 0 | 1 | 4 | 9 | B)RPSHADZKW Epassword]

Aggiunge files ad un archivio.

Archivio:

il nome e il perocrso del file zip che si desidera creare (es.: "C:\Windows\Desktop\Test.zip").

File1 .. fileN:

nome e percorso del file che si desidera comprimere; inserirne tanti quanti se ne desidera comprimere (vedi esempi in basso).

-NUM:

comando per la selezione del tipo di compressione.
Può essere:

  • N - compressione standard, aggiunge files all'archivio;

  • U - aggiorna i files già zippati con le relative versioni più recenti ,ma non aggiunge files nuovi all'archivio;

  • M - sposta files, dopo l'inserimento nell'archivio il file originale viene cancellato. USARE CON CAUTELA;

-0149BMRPSHADZKWEpassword:

opzioni per la compressione. E' possibile usare combinazioni variedi queste.
Significato:

  • 0|1|4|9|B - livello di compressione, ove 0 è il minimo e B è il massimo. Usare solo uno di questi;

  • R - includi sottocartelle, nel caso che si indichi il percorso di una cartella, verrà incluso il contenuto delle sottocartelle di quella;

  • P - salva percorso originale di ogni file;

  • S (da usare SOLO INSIEME A "P") - salva il percorso relativo del file;

  • H - aggiunge files nascosti all'archivio;

  • A - aggiunge solo i files con l'attributo "archivio";

  • D - salva i nomi dei files in formato DOS;

  • K - mostra indicatore di progressione;

  • W - salva anche le cartelle vuote;

  • E - Protegge con password (facoltativa: se non inserita, ZipGenius chiederà l’inserimento manuale di una password)

Il comando -add può essere usato anche per zippare una o più cartelle (vedi esempi 6 e 7). E' consigliabile l'uso delle virgolette per indicare percorsi di cartelle il cui nome contiene spazi. Questo comando accetta i caratteri jolly come "*".

Esempio 1 - aggiungere il file test.txt all'archivio arctest.zip, usando il livello massimo di compressione e salvando il percorso originale del file:
zg.exe -add arctest.zip test.txt -N -9P

Esempio 2 - aggiungere il file test.txt all'archivio arctest.zip, usando il livello massimo di compressione e salvando il percorso originale del file. Proteggerlo con la password “tuttifrutti”:
zg.exe -add arctest.zip test.txt -N -9PEtuttifrutti

Esempio 3 - aggiungere il file test.txt all'archivio arctest.zip, usando il livello massimo di compressione e salvando il percorso originale del file. Proteggerlo con password, che verrà inserita manualmente:
zg.exe -add arctest.zip test.txt -N -9PE

Esempio 4 - il file test.txt è già nell'archivio arctest.zip ma vogliamo aggiornarlo con la versione più recente, e inoltre vogliamo aggiungere il file test.doc all'archvio:
zg.exe -add arctest.zip test.doc test.txt -U

Esempio 5 - aggiungere il contenuto della cartella C:\test all'archivio Test.zip:
zg.exe -add test.zip "C:\Test\*.*" -N -9

Esempio 6 - aggiungere il contenuto delle cartelle C:\Test e C:\Test2 all'archivio Test.zip. Il parametro "P" non è obbligatorio ma è utile nel caso si vogliano zippare più files omonimi contenuti in due o più cartelle:
zg.exe -add test.zip "C:\Test\*.*" "C:\Test2\*.*" -N -P

-backup

  • Sintassi 1: zg.exe -backup destinazione tipo [-CDUK]
  • Sintassi 2: zg.exe -backup -F C[1|5|9|B]URPK archivio cartella [+|-file1]...[+|-fileN])

Crea il backup di una cartella.

La prima sintassi va usata per creare backup generici di cartelle (tutti i files senza esclusioni) o di appositi elementi del sistema, elencati di seguito; la seconda sintassi, invece, consente di eseguire il backup di cartelle in modo più dettagliato, dal momento che consente di indicare quali files includere o rimuovere dallla lista di archiviazione.

"Destinazione": il percorso in cui dovrà essere salvato lo zip con il backup selezionato.

Tipo può essere:

  • >MUSIC< - Backup della cartella Musica (solo Windows XP)

  • >PICS< - Backup della cartella Immagini (solo Windows 2000 e XP)

  • >VIDEO< - Backup della cartella Video (solo Windows XP)

  • >FAVORITES< - Backup della cartella Preferiti

  • >DOCS< - Backup della cartella Documenti

  • >DESKTOP< - Backup del Desktop

  • >FONTS< - Backup della cartella Fonts

  • Percorso di una cartella (es.: "C:\Test\SubTest")

Parametri:

  • C: attiva la compressione dei files durante il backup.

  • D: inserisce la data (nel formato YYYYMMDD) e l'ora nel nome del file.

  • U: aggiorna files già inseriti nell'archivio e aggiunge nuovi files.

  • K: mostra l'indicatore di avanzamento

Se si vuole eseguire il backup di una cartella di propria preferenza anziché usare un TIPO predefinito, è consigliabile indicarne il percorso fra virgolette.

Esempio 1 - eseguire il backup della cartella Preferiti e posizionare l'archvio sul desktop:
zg.exe -backup "C:\Windows\Desktop" >FAVORITES<

Esempio 2 - eseguire il backup della cartella Immagini, comprimere i files e salvare l'archivio nella cartella "C:\Out":
zg.exe -backup "C:\Out" >PICS< -C

Esempio 3 - eseguire il backup della cartella Documenti, salvare il file in "C:\Test", sincronizzare il contenuto dell'archivio con quello della cartella (nel caso che l'archivio esista già):
zg.exe -backup "C:\Test" >DOCS< -U

Esempio 4 - eseguire il backup della cartella C:\Test, salvare il file in "C:\Test2", scrivere data e ora nel nome del file:
zg.exe -backup "C:\Test2" "C:\Test" -D

Backup dettagliati.
Quando si ha la necessità di zippare cartelle in modo dettagliato, aggiungendo o escludendo singoli files o tipi di files, bisogna usare il comando -F dopo -backup, quindi indicare le opzioni di compressione.

Opzioni di compressione:

  • C - imposta il livello di compressione. Esempio: "C1" imposta il libello 1, "CB" imposta il livello brutale. I valori possibili sono 1, 5, 9, B. Indicare la sola "C" per archiviare i files senza compressione.

  • U - aggiorna i files già presenti in un archivio preesistente e aggiunge i files non già inseriti.

  • R - aggiunge anche il contenuto delle sottocartelle.

  • P - aggiunge il percorso originale dei files.

  • K - mostra un indicatore di avanzamento.

Supponiamo, per esempio, di voler eseguire il backup della cartella "C:\test\" ma vogliamo anche che i files ".DOC" non siano inclusi nel backup. Scriveremo:

zg -backup -F -CBURP "C:\Windows\Desktop\Archivio.zip" "C:\Test" +*.* -*.doc

Possiamo indicare quanti tipi di file vogliamo includere o escludere: l'importante è indicare "+" prima di un file (o un tipo di file) per inserirlo nel backup oppure "-" per escluderlo dal backup.

-oerestore

  • Sintassi: zg.exe -oerestore archivio

Ripristina le cartelle e i messaggi di Outlook Express automaticamente.

Basta indicare il percorso del file zip contenente il backup di Outlook Express e ZipGenius ripristinerà i files .DBX nella cartella corretta. ATTENZIONE: i files .DBX eventualmente già esistenti verranno sovrascritti.

-extract

  • Sintassi: zg.exe -extract archivio [file1 file2 ... fileN] [-APODKEpassword] "Destinazione"

Estrae i files da un archivio.

  • A: Estrae tutti i files.

  • P: Usa i percorsi salvati.

  • O: Sovrascrivi sempre files esistenti.

  • D: Apre la cartella di destinazione

  • K: Mostra l'indicatore di avanzamento dell'operazione

  • E: usa la password (facoltativa: se non inserita, si dovrà inserirla manualmente)

La cartella di destinazione deve essere indicata come ultimo parametro.

Se viene indicato qualche nome di file da estrarre e contemporaneamente si usa il parametro –A, solo quest’ultimo avrà effetto; se nessun parametro è indicato e nessun file da estrarre è elencato, l’estrazione avverrà come se fosse stato usato il paramtero –A.

Esempio 1 - estrarre tutti i files dall'archivio arctest.zip nella cartella C:\Test usando i percorsi originali:
zg.exe -extract arctest.zip -AP c:\test

Esempio 2 - estrarre tutti i files .DOC dall'archivio arctest.zip nella cartella C:\Test:
zg.exe -extract arctest.zip *.doc c:\test

Esempio 3 - estrarre tutti i files .DOC dall'archivio arctest.zip nella cartella C:\Test; se l’archivio è protetto usa la password “tuttifrutti”:
zg.exe -extract arctest.zip *.doc –Etuttifrutti c:\test

-delete

  • Sintassi: zg.exe -delete archivio [file1 file2 ... fileN]

Cancella files da un archivio

Esempio 1 - per cancellare tutti i files dall'archivio arctest.zip:
zg.exe -delete arctest.zip *.*

Esempio 2 - per cancellare il file test.txt dall'archivio arctest.zip:
zg.exe -delete arctest.zip test.txt

Esempio 3 - per cancellare tutti i files .DOC dall'archivio arctest.zip:
zg.exe -delete arctest.zip *.doc

-destroy

  • Sintassi: zg.exe -destroy archivio

Distrugge un archivio.

Esempio: zg.exe -destroy arctest.zip

-print

  • Sintassi: zg.exe -print archivio

Stampa la lista dei files di un archivio.

Esempio: zg.exe -print arctest.zip

-export

  • Sintassi: zg.exe -export "archivio" formato "destinazione" [-Q]

Esporta la lista dei files di un archivio nel formato indicato.

Indicare il formato dopo il nome del file-archivio:

  • HTML: esporta la lista in un pagina Web.
  • CSV: esporta la lista in un documento con valori separati da virgole.
  • XML: esporta la lista in un file XML.
  • TXT: esporta la lista in un documento di testo.

Usa il parametro -Q per sopprimere il messaggio di conferma alla fine dell'operazione.

Esempio 1 - esporta la lista dei files dell'archivio arctest.zip in un pagina Web:
zg.exe -export "C:\Test\arctest.zip" HTML "c:\Windows\Desktop"

Esempio 2 - esporta la lista dei files dell'archivio arctest.zip in un documento XML ma l'esecuzione verrà sospesa per chiedere la cartella di destinazione del file:
zg.exe -export "C:\Test\arctest.zip" XML

-mail

  • Sintassi: zg.exe -mail archivio1 [archivio2 ... archivioN]

Spedisce uno o più archivi via e-mail.

Esempio: zg.exe -mail arctest.zip

-sfx

  • Sintassi 1: zg.exe -sfx -template
  • Sintassi 2: zg.exe -sfx archivio -IT|US fileopzioni

Crea un archivio autoestraente da un archivio zip oppure genera il modello per le opzioni.

Così come spiegato nella sezione relativa alla creazione di archivi SFX, ZipGenius consente la creazione di archivi SFX con le stesse opzioni disponibili quando si esegue tale operazione dal programma.

Per poter creare un archivio SFX da un file zip è necessario creare un file delle opzioni. Usando il comando ZG -SFX -TEMPLATE, ZipGenius generà un modello di file opzioni sul Desktop. In questo file sono inizialmente riportate le impostazioni predefinite, ma - ovviamente - è possibile modificarle secondo le proprie esigenze. Di seguito sono riportate le opzioni con i valori che è possibile indicare.

Title

scrivere qui il titolo che apparirà nella finestra del file SFX

MsgType
0 - messaggio semplice (solo il tasto "OK")
1 - informazione (tasti "OK" e "Annulla")
2 - richiesta (tasti "Sì" e "No")
MsgText
Testo del messaggio che si desidera far apparire all'avvio del file SFX. Se non si desidera alcun messaggio lasciare in bianco
Autorun
0 - FALSO: l'autorun di un file è disabilitato
1 - VERO: autorun abilitato, vedi RunFile e AskAutorun.
RunFile
Indica il percorso completo del file da eseguire automaticamente. Es.: RunFile="\Test\Testfile.exe", oppure: RunFile = "Setup.exe". Se il file da eseguire è stato archiviato con le informazioni sul percorso originale, anche questo deve essere indicato come nel primo esempio. E' sempre consigliato l'uso delle virgolette (").
AskAutorun
0 - FALSO: nasconde la casella che consente di disabilitare l'autorun dal file SFX
1 - VERO: mostra la suddetta casella
DestPath
Scrivere qui il percorso di destinazione predefinito che apparirà nella finestra del file SFX. E' possibile indicare i valori spiegati nell'apposita sezione Creare un archivio autoestraente.
DestSubPath
Scrivere qui la sottocartella di destinazione che il file SFX dovrà creare. Per ulteriori spiegazioni leggere Creare un archivio autoestraente.
OvrType
0 - in caso di files omonimi preesistenti chiede se sovrascriverli
1 - sovrascrive sempre i files preesistenti
2 - salta l'estrazione di files in caso ne esistano copie preesistenti
HideOvrBox
0 - FALSO: mostra nella finestra del file SFX la casella per la scelta della modalità di sovrascrittura
1 - VERO: nasconde la casella per la scelta della modalità di sovrascrittura
SelectFile
0 - FALSO: impedisce che l'utente finale possa modificare la lista dei files da estrarre
1 - VERO: consente all'utente finale di scegliere i files da estrarre
ShowSuccessMsg
0 - FALSO: al termine dell'estrazione dei files non mostra alcun messaggio
1 - VERO: al termine dell'estrazione mostra un messaggio di operazione conclusa
ExpandEnvVars
0 - FALSO: se nel percorso di destinazione (DestPath) sono incluse variabili d'ambiente nel formato %...%, queste non sono interpretate (sconsigliato)
1 - VERO: interpreta le variabili d'ambiente nel formato %...% presenti in DestPath
HideFileList
0 - mostra la lista dei files
1 - nasconde la lista dei files solo all'avvio del file SFX: può essere resa visibile mediante il tasto "Mostra files" presente nella finestra del file SFX
2 - nasconde SEMPRE la lista dei files
AllowCancel
0 - FALSO: impedisce l'interruzione dell'estrazione dei files
1 - VERO: consente l'interruzione dell'estrazione dei files
Icon
Scrivere qui il percorso dell'icona che si deisdera associare al file SFX. Il percorso deve essere racchiuso fra virgolette (") e l'icona deve consistere in un file .ICO. Se il percorso del file icona è errato o inesistente, ZipGenius userà l'icona predefinita. Lasciare in bianco per usare comunque l'icona predefinita.

La seconda forma di sintassi è quella che invece consente di convertire in SFX un file zip. L'uso di questo comando è quindi estremamente semplice in quanto basta indicare:

  1. L'archivio zip da convertire
  2. La lingua del modulo SFX da usare (può essere -IT o -US)
  3. Il percorso del file delle opzioni

Per comprendere meglio basta guardare gli esempi seguenti.

Esempio 1: zg.exe -sfx test 1.zip -IT test1opz.txt
 (questo comando creerà un file SFX in italiano e leggerà le opzioni dal file test1opz.txt)

Esempio 2: zg.exe -sfx "C:\test\test1.zip" -US "C:\Documenti\test1opz.txt"
(questo comando creerà un file SFX in inglese e leggerà le opzioni dal file test1opz.txt, che è salvato nella cartella Documenti)

-optim

  • Sintassi 1: zg.exe -optim NOMEFILE -PM

Questo comando avvia l'ottimizzazione dei documenti di OpenOffice.org.

Opzioni:

  • P - mostra un indicatore di avanzamento.
  • M - mostra un messaggio al termine dell'operazione.

Esempio: zg.exe -optim "C:\Test\MyDoc.sxw" -P

-encrypt

  • Syntax 1: -encrypt (filename.zip) C|E S|L|D 0 P|N Key1 Key2 Key3 [AuthorName][AuthorMail]
  • Syntax 2: -encrypt (filename.zip) C|E S|L|D 1|2|3 Passphrase [AuthorName] [AuthorMail]

Questo comando consente la conversione dei files ZIP in archivi crittografati CZIP.

Tipo di archivio:

  • C - file CZIP standard, richiederà ZipGenius (o programma compatibile) per la successiva apertura;
  • E - file CZIP eseguibile, autodecifrante, non richiederà alcun programma per la successiva apertura.

Protezione archivio:

  • S - protezione standard, possibili infiniti tentativi di apertura;
  • L - file autobloccante, dopo tre tentativi falliti l'archivio è bloccato;
  • D - file autocancellante, dopo tre tentativi falliti l'archivio azzera i dati contenuti in esso.

Algoritmo di cifratura:

  • 0 - CZIP 2.1. Usando questo algoritmo, sono disponibili le seguenti opzioni:
    • Indicatore di progressione:
      • P - indicatore visibile
      • N - indicatore non visibile
    • Chiave CZIP (xxxxx-yyyyy-zzzzz):
      • Key1 - prima parte della chiave
      • Key2 - seconda parte della chiave
      • Key3 - terza parte della chiave
  • 1 - Blowfish 128 bit *
  • 2 - Twofish *
  • 3 - Rijndael (AES) *

* Gli algoritmi 1, 2, 3 mettono a dispozione solo l'opzione:

Passphrase - frase d'accesso: se contiene spazi, deve essere chiusa fra virgolette.
Es.: frase di prova -> "frase di prova"

Informazioni opzionali (comuni a tutti gli algoritmi):

  • AuthorName - nome dell'autore dell'archivio
  • AuthorMail - indirizzo e-mail dell'autore

NOTA: selezionando l'opzione "E" per la creazione di un file CZIP eseguibile, il programma imposterà automaticamente le opzioni per la produzione di un archivio CZIP con protezione standard; per motivi tecnici, infatti, non è ancora possibile produrre CZIP eseguibili autobloccanti/autocancellanti.

Antivirus | Multivolume | Crittografia | Scan e Zip | ZG Album | Linea di comando | Esportare la lista dei file | Funzioni di Backup | Ottimizzazione documenti OpenOffice.org | Ottimizzazione skin Winamp/WMP | Funzioni di ricerca | MultiOpen


Linea di comando

Operazioni avanzate

Esportare la lista dei files

ZipGenius 5 offre la possibilità di esportare la lista dei files inseriti in qualsiasi tipo di archivio supportato dal programma. Tale lista può essere esportata in modi diversi:

  • HTML - ZipGenius crea un file HTML (una pagina Web).
  • CSV - ZipGenius crea un file leggibile dalla maggior parte dei databases esistenti (valori separati da virgole).
  • XML - ZipGenius crea un file XML
  • TXT - ZipGenius crea un file visualizzabile con il Blocco Note di Windows.

Configurazione NORMALE

  • Nella barra dell’”Assistente Primo Passo” selezionare il tipo di esportazione (es.: "Esporta lista in HTML ");

  • indicare in quale cartella creare il file con la lista.

In alternativa è possbile utilizzare la voce “Esporta Lista File” del menu “strumenti” la quale esporterà la lista nel formato indicato nelle Opzioni.

Configurazione ESPERTO

Gli utenti esperti hanno a disposizione le voci “Esporta…” presenti nella sezione “Altre Operazioni” della Barra Operazioni comuni oppure le corrispondenti voci nel menu “Strumenti” . Se nelle opzioni non è stato indicato un formato di esportazione preferito, la voce “Esporta lista file” del menu “Strumenti” visualizzerà un sottomenu con tutti i formati di esportazione, altrimenti verrà visualizzata una sola voce premendo la quale la lista sarà esportata nel formato preferito indicato nelle opzioni. Fatto ciò, basterà indicare in quale cartella ZipGenius dovrà creare il file nel formato prescelto.

Antivirus | Multivolume | Crittografia | Scan e Zip | ZG Album | Linea di comando | Esportare la lista dei file | Funzioni di Backup | Ottimizzazione documenti OpenOffice.org | Ottimizzazione skin Winamp/WMP | Funzioni di ricerca | MultiOpen


Linea di comando

Operazioni avanzate

Funzioni di backup

Sebbene Windows sia diventato sempre più stabile rispetto alla prime edizioni, ancora oggi è fondamentale creare delle copie di sicurezza di parti vitali del sistema, per proteggere i tuoi dati e il tuo lavoro (copie di BackUp)

Da alcune ricerche, però, risulta che ben pochi sono gli utenti abituati ad eseguire regolari backup dei propri documenti o dei files di sistema, e le cause generalmente sono due:

  • eccessiva complessità d'uso dei programmi a questo preposti;
  • timore di compiere azioni in grado di danneggiare il sistema.

ZipGenius 5 rimuove entrambe queste cause e da oggi offre un'ampia scelta di backup predefiniti, più la possibilità di fare il backup di una cartella a scelta.

Le funzioni di Backup sono raggiungibili dal menu “Backup” il quale a sua volta e diviso in due sezioni:

1) OPZIONI di BACKUP

"Comprimi files":
clicca qui per selezionare o meno questa opzione: se selezionata i files che saranno coinvolti nel backup saranno compressi al livello massimo e l'operazione risulterà più lenta; in compenso l'archivio che sarà generato occuperà meno spazio sul disco.

"Data e ora nel nome file":

questa opzione inserisce nel nome del file la data e ora di creazione dell'archivio. Il nome del file avrà quindi un formato simile al seguente: nomefile_YYYYMMDD_HHmm.zip, ove YYYY è l'anno, MM il mese, DD il giorno, HH l'ora e "mm" i minuti.

"Aggiorna Archivio”:

se un archivio di Backup precedente contiene files con lo stesso nome di quelli che stanno per essere aggiunti, ZipGenius sostituisce quelli archiviati con quelli da archviare solo se questi ultimi sono più recenti.

2) SELEZIONE BACKUP

Personalizzato

"Cartella...":

permette di eseguire il backup di una cartella a propria scelta.

Cartelle comuni

"Cartella Documenti":
esegue il backup della cartella documenti e genera il file Documents.zip.

"Cartella di Windows":
esegue il backup della cartella in cui è installato Windows e genera il file Windows.zip. ATTENZIONE: il file generato potrebbe avere dimensioni superiori a 300 Mb.

"Cartella di sistema":
esegue il backup della cartella SYSTEM di Windows e genera il file System.zip. ATTENZIONE: il file generato potrebbe avere dimensioni superiori a 200 Mb.

"Messaggi di Outlook Express":
esegue una copia di sicurezza dei messaggi di tutte le "identità" di Outlook Express 5.x o 6.x e genera il file OE_bak.zip.

"Rubrica di Windows":
esegue una copia di sicurezza della Rubrica attualmente in uso da Windows e genera il file WAB_bak.zip.

"Preferiti di IE":

permette di eseguire il backup dell'elenco dei Preferiti di Internet Explorer.

"Files del Registro di Windows":
esegue una copia di sicurezza del registro di configurazione. ZipGenius copierà i files "system.dat", "user.dat", "system.ini" e "win.ini" in un archivio ".cab" compatibile con "ScanReg ", così a poter recuperare interamente il registro di configurazione, l'utilità di controllo e ripristino del registro incorporata in Windows 98. Il file generato sarà rb100.cab e sarà posizionato nella cartella SYSBCKUP di Windows (es.:"c:\windows\sysbckup").

Per motivi di sicurezza, questa opzione non è disponibile se ZipGenius è in esecuzione in Windows 2000/XP: se si tentasse di ripristinare i files del registro manualmente, il sistema interpreterebbe questa azione come un tentativo di violazione e costringerebbe alla reinstallazione del sistema operativo.

Cartelle di Windows XP

"Cartella Musica":

permette di eseguire il backup della cartella "Musica" solo su Windows XP.

"Cartella Immagini":

permette di eseguire il backup della cartella "Immagini" solo su Windows XP e Windows 2000.

"Cartella Video":

permette di eseguire il backup della cartella "Video" solo su Windows XP.

"Cartella Fonts":

permette di eseguire il backup della cartella contenete i caratteri (Fonts) solo su Windows XP e Windows 2000.

A partire da ZipGenius 5.5 è possibile aggiungere fino a 5 cartelle personali nel menù dei backup: in questo modo è possibile avviare il backup di una propria cartella in modo diretto e senza doverla selezionare ad ogni accesso.

Antivirus | Multivolume | Crittografia | Scan e Zip | ZG Album | Linea di comando | Esportare la lista dei file | Funzioni di Backup | Ottimizzazione documenti OpenOffice.org | Ottimizzazione skin Winamp/WMP | Funzioni di ricerca | MultiOpen


Linea di comando

Operazioni avanzate

Ottimizzazione documenti di OpenOffice.org

OpenOffice.org e StarOffice 6.x producono documenti basati sullo standard XML, mediante l'uso di un file XML per ilcontenuto, uno per lo stile e così via; quando il documento viene salvato, questi programmi creano un file zip con tutti i files XML necessari e cambiano l'estensione da .ZIP a .SX* (secondo il programma della suite usato). Il lato negativo è che questi zip non sono compressi usando il massimo livello di compressione disponibile, quindi si spreca la possibilità di creare documenti veramente compatti. ZipGenius risolve questo problema con la funzione di ottimizzazione: giacché ZipGenius può trattare i documenti di OPenOffice.org come se fossero files ZIP comuni, tutto il contenuto del documento (i files contenuti nell'archivio/documento) vengono estratti in una cartella temporanea, quindi ZipGenius li ricomprime usando il livello di compressione "Brutale". Con questo sistema un documento di OpenOffice.org si riduce dall'1 al 7%.

L'ottimizzazione può anche essere eseguita senza dover aprire ZipGenius: basta abilitare il supporto a questi documenti nel pannello delle opzioni, nella pagina "Integrazione con Windows", e cliccando col tasto destro del mouse su un documento di questo tipo apparirà il menù contestuale correlato, con due nuove voci; una di queste è "Ottimizza": cliccando questo comando il documento sarà ottimizzato come descritto.

Ogni volta che si tenta di ottimizzare un documento di OpenOffice.org, ZipGenius verifica se il file possiede il commento "ZG": la presenza di questo commento indica che il documento è già stato ottimizzato, poiché ZipGenius scrive questo commento ogni volta che ottimizza un documento di OpenOffice.org. Questo commento non influenzerà la visualizzazione del documento e verrà cancellato automaticamento al successivo aggiornamento del file da OpenOffice.org.

Per ogni documento ottimizzato, ZipGenius crea una copia di backup con estensione .BAK nella stessa cartella del file originale.

ATTENZIONE: è possibile eseguire l'operazione di ottimizzazione anche su documenti crittografati, ma il documento potrebbe essere danneggiato. Prima di procedere con l'ottimizzazione, accertarsi che il file di OpenOffice.org/StarOffice non sia crittografato.

Antivirus | Multivolume | Crittografia | Scan e Zip | ZG Album | Linea di comando | Esportare la lista dei file | Funzioni di Backup | Ottimizzazione documenti OpenOffice.org | Ottimizzazione skin Winamp/WMP | Funzioni di ricerca | MultiOpen


Linea di comando

Operazioni avanzate

Ottimizzazione skin WinAmp / Windows Media Player

Quando scarichi skin addizionali per Winamp e Windows Media Playe, forse non sai che si tratta di comuni file zip. Rinomina un file ".WAL" o ".WMZ" in “ZIP” per aprirlo.
Sorpreso? Bene, ZipGenius ti permette di ottimizzare questi file di skin proprio come fa con i documenti di OpenOffice.org e StarOffice. ZipGenius, infatti, può estrarre i file da un file di skin e ricomprimerlo al livello di compressione brutale. Grazie a questa caratteristica, i file di skin saranno ridotti dell' 1-7% rispetto agli originali. In questo caso, però, le skin non possono essere ottimizzate dal menu contesuale di Windows, ma solo tramite il menu contesuale di ZipGenius: fai clic su "Apri", scegli un file di skin e fai click col destro nella finestra di ZipGenius. Quindi, scegli "Ottimizza skin" dal menu contestuale.

Per motivi di sicurezza, quando ottimizzi una skin, ZipGenius crea una copia di scorta del file originale con estensione ".BAK" , in modo che, in caso di problemi, puoi ripristinare la copia del file; inoltre, ZipGenius aggiunge un commento al file (si tratta di un normale commento per file zip): "ZG". Questo commento serve a controllare se il file è stato già ottimizzato o no.

Antivirus | Multivolume | Crittografia | Scan e Zip | ZG Album | Linea di comando | Esportare la lista dei file | Funzioni di Backup | Ottimizzazione documenti OpenOffice.org | Ottimizzazione skin Winamp/WMP | Funzioni di ricerca | MultiOpen


Linea di comando

Operazioni avanzate

Funzioni di ricerca

RICERCA ARCHIVI
ZipGenius permette di cercare gli archivi presenti nel computer, aprirli e stamparli.

Per fare questo puoi:

  • fare clic sulla voce “Cerca Archivi” presente nella pagina dei tips, che viene mostrata all’avvio di ZipGenius.
  • in modalità “ESPERTO”, fare clic sul pulsante di scorrimento che appare nella voce “Apri” e fare clic sulla voce “Cerca Archivi”

A questo punto nela finestra di ricerca seleziona i tipi di file che ti interessano, l’unità o le cartelle in cui effettuare la ricerca e fai clic su “Avvia”. ZipGenius visualizzerà i file individuati e tipermeterà di aprirli o stamparli facendo clic sulle apposite voci “Apri” e “Stampa”

RICERCA FILE ALL’INTERNO DI UN ARCHIVIO
ZipGenius permette di cercare file all’interno di un archivio in base ad alcuni criteri di ricerca. Questa funzione si dimostra utile in presenza di archivi molto grandi. Per attivare la ricerca dei file basta fare clic sul pulsante “Pannelli” e selezionare la voce “Trova file”. A questo punto occorre selezionare i criteri di ricerca nell’aposita casella a scorrimento:

  • Comicia con…. : cerca i file che cominciano con una sequenza di caratteri indicati da te nella casella di ricerca sottostante

  • Uguale a: cerca i file che hanno il nome esattamente corrispondente a quello indicato da te nella casella di ricerca sottostante

  • Finisce con…: cerca i file che finiscono con una sequenza di caratteri indicati da te nella casella di ricerca sottostante

  • Contiene: cerca i file che contengono una sequenza di caratteri indicati da te nella casella di ricerca sottostante

Una volta impostati i criteri fai clic su "Avvia": verranno mostrati i file trovati; facendo doppio clic su uno di essi, verrà immediatamtne evidenziato nella finestra di ZipGenius.

Antivirus | Multivolume | Crittografia | Scan e Zip | ZG Album | Linea di comando | Esportare la lista dei file | Funzioni di Backup | Ottimizzazione documenti OpenOffice.org | Ottimizzazione skin Winamp/WMP | Funzioni di ricerca | MultiOpen


Linea di comando

Operazioni avanzate

MultiOpen
ZipGenius offre oggi la possibilità di aprire e gestire più archivi contemporaneamente mediante MultiOpen. Per attivare questa funzione, basta cliccare su "Apri" e selezionare più di un archivio; il programma mostrerà l'elenco dei files del primo archivio soltanto, mentre sopra la lista dei files apparirà una serie di "linguette", ciascuna associata ad uno degli archivi aperti.

Cliccando su una delle linguette, ZipGenius aprirà l'archivio corrispondente e lo tratterà come se fosse stato aperto direttamente tramite il bottone "Apri", quindi mettendo a disposizione tutte le funzioni disponibili per il formato dell'archivio selezionato.

Cliccando con il tasto destro del mouse sulle linguette, apparirà un menù con le seguenti voci:

  • Raggruppa archivi in un unico zip
    Questo comando avvia la creazione di un archivio zip nel quale saranno inseriti tutti gli archivi presenti in elenco.
  • Mescola archivi in un unico zip
    Questo comando "fonde" il contenuto di tutti gli archivi aperti in un unico zip, organizzando i files in tante cartelle quanti sono gli archivi in elenco; ogni cartella prenderà il nome dall'archivio di provenienza e conterrà l'esatto contenuto di questo. ATTENZIONE: per alcuni archivi è necessaria l'installazione del programma esterno, dal momento che quest'operazione si basa - innanzi tutto - sull'estrazione dei files dall'archivio di provenienza.
  • Chiudi archivio
    Chiude l'archivio attualmente aperto è lo elimina dalla lista.
  • Chiudi tutti gli archivi
    Chiude tutti gli archivi e pulisce la lista.
  • Estrai tutto da tutti gli archivi in cartelle separate
    Avvia la decompressione del contenuto di tutti gli archivi correntemente aperti verso un'unica cartella di destinazione, nella quale verrà creata una sottocartella per il contenuto di ciascun archivio.

MultiOpen si attiva automaticamente quando si selezionano più archivi dopo aver premuto "Apri"; se è stato aperto un solo archivio all'inizio, è possibile aggiungere successivamente altri archivi alla lista MultiOpen dal menù collegato al tasto "Apri": basta aprire il menù e cliccare su "Aggiungi archivio alla lista MultiOpen".

Inoltre, a partire dalla versione 5.2, ZipGenius è programmato per far sì che venga eseguita una sola istanza del programma, pertanto, se si fa doppio click su un archivio associato al programma mentre questo è già in esecuzione e già in una sessione multiopen, ZipGenius aggiungerà tale archivio alla lista di MultiOpen.

A partire da ZipGenius 5.2 è anche possibile copiare uno o più files da un archivio all'altro, purché l'archivio di destinazione sia uno ZIP: basta selezionare uno o più files in elenco e cliccare con il tasto destro del mouse, quindi aprire la voce "Azioni di MultiOpen" e scegliere fra:

  • Copia in... - copia i files selezionati in uno degli archivi zip elencati nel sottomenù
  • Copia in tutti gli archivi aperti - copia i files in ciascuno degli archivi zip presenti in multiopen.

La pressione del tasto "Chiudi" durante una sessione di multiopen non chiuderà subito l'archivio ma farà chiedere al programma se l'utente desidera chiudere tutti gli archivi aperti; in caso di risposta negativa, ZipGenius chiuderà soltanto l'archivio aperto e ne rimuoverà la linguetta corrispondente.

Antivirus | Multivolume | Crittografia | Scan e Zip | ZG Album | Linea di comando | Esportare la lista dei file | Funzioni di Backup | Ottimizzazione documenti OpenOffice.org | Ottimizzazione skin Winamp/WMP | Funzioni di ricerca | MultiOpen


Linea di comando

ZGTools

Cosa sono gli ZGTool?

ZipGenius si caratterizza per la presenza degli ZGTools, cioè piccoli programmi esterni in grado sia di collaborare con ZipGenius, sia di lavorare indipendentemente da questo; questi sono inclusi soltanto nella distribuzione SUITE di ZipGenius, quindi chi fosse in possesso dell'edizione STANDARD può scaricarli singolarmente dal sito M.Dev Software.

Gli ZGTools attualmente disponibili da M.Dev Software sono i seguenti:

  • Cutter 3 (disponibile nella versione Suite)
  • Time To Get! (opzionale per tutte le versioni di ZipGenius)

Come detto, questi sono prodotti da M.Dev Software, ma altri sviluppatori possono creare ZGTool installabili in ZipGenius 5 (vedi ).

Per installare uno ZGTool l'utente non deve far niente, dato che ognuno di essi (esclusi quelli prodotti da M.Dev Software, compresi quelli non distribuiti con le edizioni STANDARD e PLUS di ZipGenius) dispone del proprio programma di installazione, che provvede ad aggiungere uno o più comandi relativi allo ZGTool nel menù "Strumenti" di ZipGenius.

ZipGenius cerca e installa nuovi ZGTools ogni volta che viene avviato, ma è in grado di rilevare eventuali modifiche al file TOOLS.ini (nel quale sono registrati gli ZGTools): pertanto è possibile installare nuovi ZGTools anche se ZipGenius è in esecuzione.

ZipGenius Tools | Creare uno ZGTool | Cutter 3 | Time To Get!


Linea di comando

ZGTools

Creare uno ZGTool

L'edizione SUITE di ZipGenius comprende anche i cosidetti ZGTools, cioè piccoli programmi che possono sia funzionare indipendentemente che unitamente al programma principale. Questi programmi sono prodotti da M.Dev Software, tuttavia anche sviluppatori terzi possono creare altri ZGTools.

Perchè uno ZGTool sia comandabile da ZipGenius è opportuni che "comunichi" la propria presenza tramite il file TOOLS.INI, reperibile nella stessa cartella in cui è installato zipgenius.exe. Nel file "tools.ini" lo strumento deve creare una sezione come indicato nell'esempio seguente:

  [Collector]
cmd=C:\COLLECTOR\COLLECTOR.EXE
caption=Colleziona
  archivi
params=-zg
results=c:\windows\deskop\result.txt
fileopen=0
senadarcname=0
sendselected=0
sendall=0

In questo esempio sono elencati tutti i parametri OBBLIGATORI da utilizzare nella sezione.

CMD
In questo parametro lo ZGTool deve indicare il proprio percorso, altrimenti ZipGenius non potrà usarlo.

CAPTION
Qui bisogna inserire la voce del menù che apparirà in fondo al menù "STRUMENTI " di ZipGenius, dal quale potrà essere avviato lo ZGTool.

PARAMS
Qui bisogna indicare gli eventuali parametri da aggiungere alla linea di comando dello strumento: vedere anche SendArcName, SendSelected e SendAll .

RESULTS
Se lo strumento che si è creato scrive un file con i risultati dell'operazione eseguita, ZipGenius lo potrà leggere tramite il percorso indicato in questo parametro.

FILEOPEN
Qui puoi indicare se lo ZGTool deve essere usato solo se è un archivio è aperto in ZipGenius: "1" significa "vero", "0" significa "falso" (lo ZGTool può funzionare sempre).

SENDARCNAME
Se questo valore è uguale a "1", alla lista dei parametri inserita in Params, sarò aggiunto il percorso e il nome del file-archivio attualmente aperto.

SENDSELECTED
Se questo valore è uguale a "1", alla lista dei parametri inserita in Params saranno aggiunti i nomi dei files selezionati nella finestra di ZipGenius.

SENDALL
Se questo valore è uguale a "1", alla lista dei parametri inserita in Params saranno aggiunti i nomi di tutti i files elencati nella finestra di ZipGenius.

Suggerimenti per lo sviluppatore:

1. Per sapere in quale cartella si trovano i files zipgenius.exe e tools.ini, basta leggere il valore AppPath contenuto nella chiave del registro di Windows:

  • ZipGenius 1.4: HKEY_CURRENT_USER\Software\M.Dev Software\ZGTools

  • ZipGenius 5: HKEY_CURRENT_USER\Software\M.Dev Software\ZG5

Lo ZGTool deve provvedere a questa operazione, quindi dovrà riportare il proprio percorso d'installazione nel valore CMD della sezione che creerà in tools.ini.

2. Puoi creare anche più di una sezione in tools.ini se il tuo strumento compie più di una azione: l'importante è che lo ZGTool provveda a creare due sezioni distinte. Esempio:

[Collector_1]
cmd=C:\COLLECTOR\COLLECTOR.EXE
caption=Colleziona archivi
params=-zg
results=c:\windows\deskop\result.txt
fileopen=0

  [Collector_2]
cmd=C:\COLLECTOR\COLLECTOR.EXE
caption=Colleziona

  archivi ZIP e CAB
params=-zg-zip -cab
results=c:\windows\deskop\result.txt
fileopen=0

3. Quando crei il setup dello ZGTool e la relativa procedura di disinstallazione, assicurati che le sezioni create dal tuo strumento siano rimosse dal file tools.ini, e che lo stesso file non sia rimosso accidentalmente.

4. Lo ZGTool non deve necessariamente essere un file eseguibile: con il metodo usato in ZipGenius puoi usare anche script in VBScript, JavaScript e files .BAT e .COM.

5. Se il tuo ZGTool crea un file di risultati, fa sì che il file stesso inizi con il nome dello ZGTool, il tuo nome e persino con il tuo indirizzo e-mail o l'indirizzo della tua homepage: ZipGenius mostrerà il file nel visualizzatore interno, che è in grado di leggere i collegamenti Internet (hyperlinks).

6. Entro breve termine verrà rilasciato una utility per la creazione della procedura di iscrizione degli ZGTools, quindi consulta periodicamente il sito M.Dev Software.

7. Puoi personalizzare il Setup del tuo ZGTool con il logo che puoi scaricare da qui.

8. Fa' in modo che l'installazione dello ZGTool rilevi la lingua in uso con ZipGenius, così da poter inserire il titolo della voce del menù nella lingua corrispondente

Per ottenere maggiore aiuto o altri suggerimenti è possibile contattare M.Dev Software.

ZipGenius Tools | Creare uno ZGTool | Cutter 3 | Time To Get!


Linea di comando

StartPage | << Indietro | Avanti >>
ZGTools

Cutter 3

Così come molti altri programmi per la compressione di files in archivi zip, anche ZipGenius dispone della funzione "Disk Spanning" per distribuire grossi archivi su un set di floppy disk; tuttavia tale funzione è - appunto - limitata ai soli files zip, mentre Cutter consente di far questo con ogni tipo di archivio e file, se viene usato come applicazione indipendente. Con Cutter si può persino scegliere la dimensione dei frammenti che risulteranno dalla divisione del files, e ad essi sarà associata una procedura automatica (in un file .bat) che consentirà al destinatario di ricostruire il file originale (anche in ambiente DOS). Questo ZGTool è completamente gestito da una procedura guidata.

ZipGenius Tools | Creare uno ZGTool | Cutter 3 | Time To Get!


Linea di comando

Internet e posta elettronica

Invio allegati e pubblicazione sul Web

ZipGenius è stata progettata per una maggiore integrazione delle funzioni per Internet. Le funzioni Internet disponibili sono:

Invia in allegato.
Per inviare un archivio, o un file in esso contenuto, come allegato potete fare clic sulla voce “Invia allegato” del menu strumenti, oppure selezionare la voce “internet” del menu contesuale di zipgenius (in ques’ultimo caso oltre alle voci relative alla posta eletronica, appariranno tutte le altre voci relative all apubblicazione sul Web). A questo punto:

  • potete inviare un intero archivio come allegato cliccando sulla voce “Archivio” (o “invia archivio come allegato” nel menu contestuale): sarà avviato il programma e-mail predefinito, già pronto per la creazione di un nuovo messaggio e con l'archivio già allegato;
  • se si seleziona un file contenuto nell'archivio correntemente aperto, nel menu “invia allegato” e “Internet” saranno disponibili rispettivamente le voci “file” e “invia file come allegto”. Tramite questa funzione, è possibile estrarre uno o più files da un archivio e invirali come allegati ad un messaggio e-mail.

Pubblica su Internet.
Anche a questa funzione è collegato un sottomenù che si comporta identicamente a quello relativo all'invio in allegato, così in modo analogo all’invio degli allegati, potrai anche pubblicare uno o più files estratti dall'archivio attualmente aperto in ZipGenius.

Per pubblicazione su Internet si intende il trasferimento di un file su un sito Web, quindi se disponi di un tuo spazio su Web puoi trasferire i tuoi archivi nello stesso spazio in cui sono ospitate le pagine del tuo sito. ZipGenius esegue ciò tramite FTPGenius, il client FTP incorporato, il quale provvederà ad avviarsi, connettersi ad un sito FTP a scelta dell'utente e a trasferire i files selezionati o l'archivio correntemente aperto.

Pubblicazione sul Web e invio allegati | FTPGenius | Codifica UU/XX/MIME Base64


Linea di comando

Internet e posta elettronica

FTPGenius

FTPGenius è il client FTP che si integra con ZipGenius. Esso può essere anche avviato direttamente come applicazione indipendente mediante gli appositi collegamenti nel menù Start e nella barra di Avvio Veloce di Windows.

Un client FTP viene usato per inviare o prelevare files da/verso server FTP connessi a Internet. FTP infatti sta per Files Transfer Protocol, ossia protocollo di trasferimento files, che è un "linguaggio" creato appositamente per questo scopo. L'FTP è usato in genere quando si desidera pubblicare un proprio sito su Internet o quando si vogliono scaricare files (drivers per periferiche, soprattutto) da siti FTP.

FTPGenius 2004 è la nuova versione di FTPGenius ed è oggi inclusa soltanto in ZipGenius 5 Suite, oppure può essere scaricata da www.zipgenius.it. L'interfaccia è leggermente cambiata: la barra più in alto consente di selezionare uno fra i siti FTP preferiti inseriti nell'elenco, e la stessa consente di aggiungere/modificare siti FTP preferiti, di connettersi al sito selezionato e di importare/esportare la lista dei preferiti.

1) CREARE UNA CONNESSIONE FTP.
Clicchiamo su NUOVO per iniziare l'inserimento dei dati del server FTP mediante l'assistente che apparirà. L'assistente ci chiederà una serie di informazioni:

  • Nome segnalibro - indicare il nome con cui il sito verrà indicato nell'elenco.
  • Indirizzo server FTP - indicare l'indirizzo del server ftp (es.: ftp.mio.com).
  • Connessione diretta / tramite proxy - occorre indicare se la connessione a Internet avviene direttamente o tramite server proxy; nel secondo caso occorre indicare anche l'indirizzo del server proxy.
  • Tipo di autenticazione - se il server FTP richiede autenticazione, bisognerà indicare username e password (la password può essere salvata così da non doverla inserire ad ogni accesso); in alternativa, è possibile impostare l'accesso anonimo (se consentito dal server).
  • Trucco della "finta attività" - molti server FTP chiudono la connessione se l'utente rimane inattivo per un certo periodo, ma abilitando questo trucco FTPGenius invierà un comando "inutile" al server per simulare attività umana e impedire la disconnessione.
  • Cartella remota iniziale e numero porta - indicare quale cartella remota mostrare subito dopo la connessione al server e quale numero di porta utilizzare (normalmente: 21).
  • Timeout del server - impostare il timeout del server per indicare dopo quanti secondi il server deve considerare decaduto un comando.
  • Trasferimenti passivi PASV - con alcuni server è bene impostare i trasferimenti passivi per garantire la riuscita dei trasferimenti di files.

Al termine l'assistente chiederà se, dopo aver memorizzato le informazioni, si desidera accedere immediatamente al server FTP indicato.

Dopo la memorizzazione il sito FTP apparirà nell'apposito elenco posto nella parte superiore della finestra di FTPGenius.

Se un PC con Windows NT, 2000 o XP, dispone di più profili utente, ognuno di essi potrà creare la propria lista di server FTP preferiti.

2) NAVIGAZIONE NEL SERVER FTP.
Con FTPGenius l'esplorazione del server avviene come se ci trovassimo in "Esplora risorse" di Windows, pertanto a sinistra vedrai un elenco ad albero, in cui sarà riportata la struttura del server con le sue sottocartelle, e a destra vedrai l'elenco dei files contenuti nella cartella attualmente aperta.

Per saltare da una cartella all'altra, clicca sull'elenco a sinistra (sul nome della cartella che intendi aprire) oppure fai doppio clic sul nome della cartella nell'elenco di destra.

3) INVIARE UNO O PIU' FILES AL SERVER.
Seleziona se eseguire un trasferimento attivo o passivo: considera che il secondo è più lento ma più stabile, mentre è consigliato il trasferimento attivo se la stabilità della tua connessione non è un problema.

Clicca "PUBBLICA" e sfoglia le cartelle di Windows per trovare i files da inviare, selezionali e clicca "OK". Se i files sono già esistenti sul server, FTPGenius chiederà per ognuno di essi se desideri sovrascrivere il file esistente sul server.

4) SCARICARE UNO O PIU' FILES DAL SERVER.
Seleziona se eseguire un trasferimento attivo o passivo: considera che il secondo è più lento ma più stabile, mentre è consigliato il trasferimento attivo se la stabilità della tua connessione non è un problema.

Sfoglia le cartelle del server con FTPGenius e seleziona i files da scaricare, quindi clicca "DOWNLOAD" per scegliere in quale cartella di Windows salvare i files. Se i files sono già esistenti nella cartella di destinazione, il programma chiederà - per ognuno di essi - se intendi sovrascrivere i files esistenti.

Durante il trasferimento dei files da/verso il server FTP apparirà un pannello indicante quanti files sono stati trasferiti fra quelli selezionati.

5) CREARE UNA NUOVA CARTELLA NEL SERVER FTP.
Se il server FTP lo consente, puoi creare una nuova cartella con il tasto "Nuova cartella".

6) CANCELLARE UN FILE O UNA CARTELLA DAL SERVER.
Seleziona il file o la cartella da cancellare e clicca "CANCELLA". Questa operazione è possibile solo se il server FTP lo consente.

7) RINOMINARE UN FILE O UNA CARTELLA DEL SERVER.
Se il server FTP lo consente, puoi selezionare un file o una cartella e cliccare sul suo nome con il tasto destro del mouse, poi potrai cliccare "RINOMINA" nel menù che apparirà.

Pubblicazione sul Web e invio allegati | FTPGenius | Codifica UU/XX/MIME Base64


Linea di comando

Internet e posta elettronica

Codifica UU, XX e Mime/Base 64

I files sono generalmente distinti in due famiglie: files "BINARI" e files "ASCII", dove questi utlimi altro non sono che files contenenti del testo; per fare un esempio, un file .zip o un file .gif sono files binari, poiché non contengono del testo ma il loro contenuto è codificato in forma "binaria" (tanti "0" e "1" in successione), mentre un file .txt è un file ASCII, giacché il contenuto è esclusivamente del testo.

In determinate occasioni su Internet non è possibile inviare files nella loro naturale forma binaria, cosicché diverrebbe impossibile il trasferimento di quei files: basti pensare ad alcuni newsgroups che accettano messaggi senza files binari allegati; in queste situazioni ZipGenius può intervenire trasformando qualsiasi tipo di file (e non solo gli archivi nei formati supportati) in files testuali che possono aggirare la suddetta limitazione; sarà poi il destinatario del file a dover decodificare quei files utilizzando il metodo inverso a quello usato per la codifica.

ZipGenius supporta tre metodi di codifica largamente diffusi.

UUencode: è il più antico fra i tre ed era originariamente progettato per i sistemi operativi UNIX. I files codificati con questo metodo sono riconoscibili per le estensioni .uu e .uue, mentre ZipGenius produce files con la sola estensione .uue.

XXencode: è un metodo simile a UUencode, ma del quale è considerato come una evoluzione volta a risolvere alcuni problemi di quello, come - per esempio - la non perfetta conversione secondo la tavola dei caratteri ASCII. I files codificati con questo sistema hanno l'estension .xxe.

MIME Base 64: questo è il metodo attualmente più diffuso poiché è nato contemporaneamente alla diffusione dei sistemi di posta elettrnoica via Internet. Tutti i programmi e-mail oggi codificano i messaggi nel formato MIME e i files codificati con questo metodo sono riconoscibili per l'estensione .mim e .b64.

Per codficare un file qualsiasi o l'archivio correntemente aperto basta aprire il menù "Azioni" e selezionare il metodo di codifica (o di decodifica) che si desidera usare: se nessun archivio è aperto in ZipGenius, il programma farà apparire un dialogo da cui potrai scegliere qualsiasi file da codificare (o decodificare). Al termine dell'operazione il programma darà conferma della riuscita e mostrerà il nome del file generato dalla codifica.

Pubblicazione sul Web e invio allegati | FTPGenius | Codifica UU/XX/MIME Base64


Visualizzazione cartelle

ZG Lab - Risoluzione problemi
F.A.Q.

Click on a question to read the related answer.

  1. Come posso aprire un file?
  2. Come posso comprimere un file?
  3. Quali tipi di files supporta ZipGenius?
  4. Come posso estrarre files da un archivio?
  5. Cos'è un archivio?
  6. Cos'è la barra "Primo Passo"?
  7. Come posso eseguire il backup di una cartella qualsiasi?
  8. Come posso eseguire il backup di immagini, musica, video, e files simili?
  9. Perché solo gli utenti di Windows XP® posso estrarre files verso il masterizzatore?
  10. ZipGenius supporta le immagini ISO?
  11. Come posso personalizzare la finestra di ZipGenius?
  12. Vorrei installare ZipGenius su più di un computer: come posso esportare le impostazioni?
  13. Perché ZipGenius non può più essere installato su Windows 95 e NT4?
  14. ZipGenius è davvero gratuito?
  15. Vorrei pagare per usare ZipGenius: dove devo spedire il mio denaro?
  16. Qualcuno mi ha chiesto del denaro per permettermi di scaricare ZipGenius: è autorizzato?
  17. Cosa sono gli ZGTools?
  18. Come posso scrivere un file batch per automatizzare alcune operazioni con ZipGenius? Avete esempi?
  19. Possiedo più di un PocketPC® sincronizzato con il mio PC desktop...
  20. Perché la sidebar a volte si disegna lentamente?
  21. Quali sono i limiti per il formato ZIP?
  22. Come posso creare una presentazione?
  23. Come funziona l'ottimizzazione dei documenti di OpenOffice.org?
  24. Cos'è l'evidenziatore di files?

Come posso aprire un file?
Puoi aprire un file in diversi modi:

  • Clicca il bottone "Apri" in ZipGenius e scegli un file
  • Trascina un file zip sul collegamento a ZipGenius che trovi sul desktop
  • Clicca con il tasto destro su un file e scegli "Apri"

Come posso comprimere un file?
La procedura di compressione di un file varia secondo il formato scelto. Immaginiamo di dover comprimere un file in un archivio zip:

  1. Se il file zip deve essere creato, clicca su "Nuovo" e indica tutti i dettagli per la creazione del nuovo archivio; se il file zip esiste già, passa al punto seguente,
  2. Clicca "Aggiungi files" per selezionare i files da comprimere, oppure clicca "Aggiungi cartella" se vuoi aggiungere il contenuto di una cartella.
  3. Vedrai apparire una finestra chiamata "Opzioni di compressione" in cui puoi modificare diverse impostazioni.
  4. Clica "Procedi" e attendi.

Quali tipi di file supporta ZipGenius?
Guarda qui.

Come posso estrarre files da un archivio?
Puoi estrarre i files in molti modi:

  • Apri un archivio in ZipGenius e clicca su "Estrai".
  • Trascina uno o più files dalla finestra di ZipGenius verso il desktop (o un'altra cartella).
  • Clicca con il tasto destro del mouse su un archivio e seleziona "Estrai" dal menù contestuale.

Per ulteriori informazioni leggi: Estrarre files e Integrazione con Windows.

Cos'è un archivio?
I files compressi sono spessi chiamati "archivi" poiché essi contengono molti files al loro interno e, spesso, sono organizzati in cartelle e sottocartelle.

Cos'è la barra "Primo Passo"?
Le precedenti versioni di ZipGenius avevano un wizard chiamato "Primo Passo", il quale veniva attivato mediante un bottone sulla barra degli strumenti principale; in ZipGenius 5, invece, l'assistente "Primo Passo" è stato trasformato in una barra degli strumenti, visibile sopra la barra dei bottoni. La barra "Primo Passo" è sempre visibile in modalità NORMALE, mentre in modalità ESPERTO si può decidere se visualizzarla o meno.

Come posso eseguire il backup di una cartella qualsiasi?
Apri il menù "Backup" e seleziona "Cartella...", quindi scegli la cartella.

Come posso eseguire il backup di immagini, musica, video e simili?
Apri il menù "Backup" e scegli la funzione appropriata.

Perchè solo gli utenti di Windows XP® possono estrarre files verso il masterizzatore?
Windows XP® è provvisto fin dall'origine di funzioni per la masterizzazione dei files, rendendo teoricamente inutile il ricorso ad altri programmi per lo stesso scopo; grazie a ciò, abbiamo potuto inserire la funzione di estrazione files verso il masterizzatore, la quale rimane disabilitata nelle altre versioni di Windows proprio a causa dell'assenza di tale supporto. Comunque sono stati svolti dei test sulla compatibilità fra ZG e Ahead InCD® e siamo riusciti ad estrarre files verso un CD-RW formattato da InCD con il filesystem UDF.

ZipGenius supporta la immagini CD-ROM in formato ISO?
Non più a partire dalla version 5.2.5.xxx.

Come posso personalizzare la finestra di ZipGenius?
Puoi modificare lo schema dei colori il font usato e la configurazione della finestra: clicca su "Opzioni" > "Aspetto".

Vorrei installare ZipGenius su più di un PC: come faccio ad esportare le impostazioni?
Questa è una nuova caratteristica. Basta cliccare su "Opzioni", quindi su "Esporta impostazioni" alla base pannello delle opzioni; così facendo, ZipGenius provvederà a scrivere le impostazioni attuali in un file .REG, il quale potrà essere installato su altri PC con ZipGenius 5 (basterà cliccare due volte sul file .REG).

Perché ZipGenius non più essere installato su Windows 95 e NT4?
Questi sistemi sono ormai obsoleti e Microsoft® sta eliminarli definitivamente; inoltre non sono più in grado di supportare le richieste di questa nuova versione di ZipGenius5, la quale è stata pensata e sviluppata soprattutto per Windows® XP.

ZipGenius è davvero gratuito? Anche per gli utenti aziendali e professionali?
Sì, lo è.

Voglio pagare per usare ZipGenius: dove devo spedire il mio denaro?
ZipGenius è gratuito, quindi non è necessario spedire del denaro.

Qualcuno mi ha chiesto del denaro per poter scaricare ZipGenius: è autorizzato?
No, nessuno è autorizzato a chiedere denaro prima di consentire il download di ZipGenius. Per favore, fornisci maggiori dettagli su questa persona a info@zipgenius.it

Cosa sono gli ZGTools?
Gli ZGTools sono piccoli programmi in grado di fare molte cose, e che possono estendere le funzioni di ZipGenius. Maggiori informazioni qui.

Come posso scrivere un file batch per automatizzare alcune operazioni di ZipGenius? Avete esempi?
Usa Blocco Note e scrivi un file di testo con i comandi di ZipGenius che trovi qui. Alla fine salva il file con l'estensione .BAT.

Possiedo più di un PocketPC® sincronizzato con il mio PC desktop...
Clicca "Opzioni" > "Dispositivo Mobile": troverai una lista con tutti i dispositivi portatili rilevati. Scegline uno e clicca "OK".

Perché la sidebar a volte si disegna lentamente?
Hai provato a cambiare i drivers della scheda video?

Quali sono i limiti del formato ZIP?
Un file ZIP file può contenere max 65536 files e la dimensione massima dell'archivio è di 4 GB. ZipGenius 5.5 adesso impiega il motore ZipForge per la gestione di questo formato e del suo discendente, ZIP64, perciò il programma può gestire anche archivi che superino i suddetti limiti. Una valida alternativa è costituita dal formato .7z.

Come posso creare una presentazione?
Prima di tutto verifica che ZG Album sia installato. Apri il menù "Azioni": vedi il comando "Crea presentazione"? Se non lo vedi, lancia il setup di ZG 5 Suite e installa ZG Album (se hai ZG 5 STD, scaricalo da www.zipgenius.it ).
Ci sono due modi per creare una presentazione:

  1. Attraverso Scan and Zip.
  2. Selezionando una cartella contenente immagini: clicca su "Crea presentazione" nel menù "Azioni", scegli la cartella con le immagini, quindi scrivi le informazioni sulla presentazione. Hai finito.

Come funziona l'ottimizzazione dei documenti di OpenOffice.org?
Quando OpenOffice.org salva un documento, altro non fa che scrivere alcuni files XML e li archivia in un file zip, al quale però viene attribuita un'estensione proprietaria. OpenOffice.org non usa il livello di compressione migliore offerto dal formato .zip, quindi ZipGenius estrae i files dal documento e li ricomprime usando il livello di compressione Brutale. Nella cartella del file ottimizzato si troverà anche una copia del file originale con l'estensione .BAK. Mediante l'ottimizzazione, quindi è possibile ridurre ulteriormente lo spazio occupato dai files generati dai programmi della suite OpenOffice.org.

Cos'è l'evidenziatore dei files?
E' una nuova caratteristica che costringe ZipGenius ad evidenziare certi files nella lista con diversi colori, secondo determinati criteri che si possono impostare nel pannello delle opzioni. Vedi qui.

Problemi e soluzioni | Contatti


Visualizzazione cartelle

ZG Lab - Risoluzione problemi
Contatti

>> Home page: www.zipgenius.it

>> Informazioni generiche su ZipGenius (non per il supporto tecnico): info@zipgenius.it

>> Supporto tecnico: support@zipgenius.it

>> Assistenza sviluppatori: info@zipgenius.it

E' consigliabile visitare spesso anche il forum del sito ZipGenius.it, ove verranno date comunicazioni urgenti in tempo reale, consigli e trucchi.

Problemi e soluzioni | Contatti


Linea di comando

ZGTools

Time To Get!

La funzione di questo ZGTool è quella di calcolare il tempo (stimato) richiesto per scaricare un file a diverse velocità di connessione.

Usarlo da ZipGenius (come ZGTool) è molto semplice: basta aprire un archivio e selezionare il comando "Time To Get!" nel menù Strumenti; il risultato apparirà nella finestra del visualizzatore interno, oppure, selezionando il comando "Time To Get! - HTML", ti sarà chiesto in quale cartella salvare il file HTML che lo ZGTool creerà.

Se usato come applicazione indipendente, invece, bisognerà:

  1. selezionare un file cliccando sul tasto "Browse";
  2. cliccare su "Calculate" per sapere i diversi tempi stimati;
  3. opzionalmente potrai cliccare su "Export to HTML" per esportare i risultati in un file HTML.

ZipGenius Tools | Creare uno ZGTool | Cutter 3 | Time To Get!


Archivi supportati da ZipGenius

Introduzione al programma

Setup automatico

Gli amministratori di sistema spesso devono installare la stessa applicazione su tutte le macchina connesse alla LAN che essi gestiscono: per questo motivo oggi ZipGenius offre la possibilità di eseguire setup automatici.

Lanciare un setup automatico è molto facile.
Cliccare Start>Esegui e digitare il seguente comando:

  • zgXXXYYY.exe /verysilent

Ove X e Y rappresentano la versione e l'edizione di ZipGenius, perciò se si scarica ZipGenius 5.5.1 Suite, il comando da digitare sarà: zg551sui.exe /verysilent.

Ovviamente questo comando può essere anche inserito in procedure automatizzate mediante script.

Introduzione | Archivi supportati da ZipGenius | Caratteristiche di ZipGenius 5 |
 Aggiornamenti | Requisiti di sistema | Setup automatico